zoukankan      html  css  js  c++  java
  • poj_1050To the Max

    To the Max
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 36015   Accepted: 18897

    Description

    Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
    As an example, the maximal sub-rectangle of the array: 

    0 -2 -7 0 
    9 2 -6 2 
    -4 1 -4 1 
    -1 8 0 -2 
    is in the lower left corner: 

    9 2 
    -4 1 
    -1 8 
    and has a sum of 15. 

    Input

    The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

    Output

    Output the sum of the maximal sub-rectangle.

    Sample Input

    4
    0 -2 -7 0 9 2 -6 2
    -4 1 -4  1 -1
    
    8  0 -2

    Sample Output

    15
    果将每一个二维矩阵的每一列的数据总和,按照列的序号分别对应地保存到一个一维数组中,就转化成一维,其性质跟求最大子段和一样,而在这里只不过要进行多次这样的计算而已 ^ -^ 经典Dynamic programming 中的经典!!!!

    #include <iostream>
    #include <cstring>
    using namespace std;
    #pragma warning(disable : 4996)
    const int MAXN = 105;
    int arr[MAXN][MAXN], dp[MAXN];
    int n;
    
    int DP()
    {
    	int thissum, maxsum;
    	thissum = maxsum = 0;
    	for (int i = 1; i <= n; i++)
    	{
    		thissum += dp[i];
    		if(thissum > maxsum)
    		{
    			maxsum = thissum;
    		}
    		if(thissum < 0)
    		{
    			thissum = 0;
    		}
    	}
    	return maxsum;
    }
    
    int main()
    {
    	freopen("in.txt", "r", stdin);
    	int i, j, k;
    	int sum, ans;
    	while(scanf("%d", &n) != EOF)
    	{
    		for(i = 1; i <= n; i++)
    		{
    			for(j = 1; j <= n; j++)
    			{
    				scanf("%d", &arr[i][j]);
    			}
    		}
    		ans = 0;
    		for (int i = 1; i <= n; i++)
    		{
    			memset(dp, 0, sizeof(dp));
    			for (int j = i; j <= n; j++)
    			{
    				for (k = 1; k <= n; k++)
    				{
    					dp[k] += arr[j][k];
    				}
    				sum = DP();
    				if(sum > ans)
    				{
    					ans = sum;
    				}
    			}
    		}
    		printf("%d\n", ans);
    	}
    }


  • 相关阅读:
    致此时的自己
    感悟
    Do what you love VS Love what you do
    感悟
    JavaScript中关于date对象的一些方法
    悟透JavaScript——学习心得
    JavaScript中关于string对象的一些方法
    JavaScript中的简单语句
    w3school CSS基础教程
    SMACSS——Scalable & Modular Architecture for CSS
  • 原文地址:https://www.cnblogs.com/lgh1992314/p/5834966.html
Copyright © 2011-2022 走看看