zoukankan      html  css  js  c++  java
  • hdoj_1428漫步校园

    漫步校园

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 2077    Accepted Submission(s): 597


    Problem Description
    LL最近沉迷于AC不能自拔,每天寝室、机房两点一线。由于长时间坐在电脑边,缺乏运动。他决定充分利用每次从寝室到机房的时间,在校园里散散步。整个HDU校园呈方形布局,可划分为n*n个小方格,代表各个区域。例如LL居住的18号宿舍位于校园的西北角,即方格(1,1)代表的地方,而机房所在的第三实验楼处于东南端的(n,n)。因有多条路线可以选择,LL希望每次的散步路线都不一样。另外,他考虑从A区域到B区域仅当存在一条从B到机房的路线比任何一条从A到机房的路线更近(否则可能永远都到不了机房了…)。现在他想知道的是,所有满足要求的路线一共有多少条。你能告诉他吗?
     

    Input
    每组测试数据的第一行为n(2=<n<=50),接下来的n行每行有n个数,代表经过每个区域所花的时间t(0<t<=50)(由于寝室与机房均在三楼,故起点与终点也得费时)。
     

    Output
    针对每组测试数据,输出总的路线数(小于2^63)。
     

    Sample Input
    3 1 2 3 1 2 3 1 2 3 3 1 1 1 1 1 1 1 1 1
     

    Sample Output
    1 6
    #include <iostream>
    #include <queue>
    #define INF 0xFFFFFFF
    using namespace std;
    #pragma warning(disable : 4996)
    
    typedef struct Node
    {
    	int x;
    	int y;
    }Node;
    queue<Node>Q;
    int n;
    int map[51][51];
    long long dp[51][51];
    int dis[51][51];
    int dir[4][2] = {{-1,0},{0,1},{1,0},{0,-1}};
    
    void bfs()
    {
    	while(!Q.empty())
    	{
    		Q.pop();
    	}
    	Node pre, next;
    	pre.x = n;
    	pre.y = n;
    	Q.push(pre);
    	dis[n][n] = map[n][n];
    	while(!Q.empty())
    	{
    		pre = Q.front();
    		Q.pop();
    		for(int i = 0; i < 4; i++)
    		{
    			next.x = pre.x + dir[i][0];
    			next.y = pre.y + dir[i][1];
    			if(next.x >= 1 && next.x <= n && next.y >= 1 && next.y <= n)
    			{
    				int tt = dis[pre.x][pre.y] + map[next.x][next.y];
    				if(dis[next.x][next.y] > tt)
    				{
    					dis[next.x][next.y] = tt;
    					Q.push(next);
    				}
    			}
    		}
    	}
    	return;
    }
    long long dfs(int x, int y)
    {
    	if(dp[x][y] > 0)
    	{
    		return dp[x][y];
    	}
    	if(x == n && y == n)
    	{
    		return 1;
    	}
    	for(int i = 0; i < 4; i++)
    	{
    		int xx = x + dir[i][0];
    		int yy = y + dir[i][1];
    		if(xx >= 1 && xx <= n && yy >= 1 && yy <= n)
    		{
    			if(dis[xx][yy] < dis[x][y])
    			{
    				dp[x][y] += dfs(xx, yy);
    			}
    		}
    	}
    	return dp[x][y];
    }
    int main()
    {
    	freopen("in.txt", "r", stdin);
    	while(scanf("%d", &n) != EOF)
    	{
    		for(int i = 1; i <= n; i++)
    			for(int j = 1; j <= n; j++)
    			{
    				scanf("%d", &map[i][j]);
    				dis[i][j] = INF;
    			}
    			bfs();
    			memset(dp, 0, sizeof(dp));
    			dfs(1, 1);
    			printf("%I64d\n", dp[1][1]);
    	}
    	return 0;
    }



  • 相关阅读:
    线程(中)
    线程
    生产者消费者模型
    进程的常用方法
    HTML中head与body标签
    HTTP协议
    mysql:视图,触发器,事务,存储过程,函数。
    关于MySQL中pymysql安装的问题。
    MySQL多表查询,pymysql模块。
    MySQL之单表查询
  • 原文地址:https://www.cnblogs.com/lgh1992314/p/5834970.html
Copyright © 2011-2022 走看看