zoukankan      html  css  js  c++  java
  • hdoj_1026Ignatius and the Princess I

    Ignatius and the Princess I

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 9183    Accepted Submission(s): 2712
    Special Judge


    Problem Description
    The Princess has been abducted by the BEelzebub feng5166, our hero Ignatius has to rescue our pretty Princess. Now he gets into feng5166's castle. The castle is a large labyrinth. To make the problem simply, we assume the labyrinth is a N*M two-dimensional array which left-top corner is (0,0) and right-bottom corner is (N-1,M-1). Ignatius enters at (0,0), and the door to feng5166's room is at (N-1,M-1), that is our target. There are some monsters in the castle, if Ignatius meet them, he has to kill them. Here is some rules:

    1.Ignatius can only move in four directions(up, down, left, right), one step per second. A step is defined as follow: if current position is (x,y), after a step, Ignatius can only stand on (x-1,y), (x+1,y), (x,y-1) or (x,y+1).
    2.The array is marked with some characters and numbers. We define them like this:
    . : The place where Ignatius can walk on.
    X : The place is a trap, Ignatius should not walk on it.
    n : Here is a monster with n HP(1<=n<=9), if Ignatius walk on it, it takes him n seconds to kill the monster.

    Your task is to give out the path which costs minimum seconds for Ignatius to reach target position. You may assume that the start position and the target position will never be a trap, and there will never be a monster at the start position.
     

    Input
    The input contains several test cases. Each test case starts with a line contains two numbers N and M(2<=N<=100,2<=M<=100) which indicate the size of the labyrinth. Then a N*M two-dimensional array follows, which describe the whole labyrinth. The input is terminated by the end of file. More details in the Sample Input.
     

    Output
    For each test case, you should output "God please help our poor hero." if Ignatius can't reach the target position, or you should output "It takes n seconds to reach the target position, let me show you the way."(n is the minimum seconds), and tell our hero the whole path. Output a line contains "FINISH" after each test case. If there are more than one path, any one is OK in this problem. More details in the Sample Output.
     

    Sample Input
    5 6 .XX.1. ..X.2. 2...X. ...XX. XXXXX. 5 6 .XX.1. ..X.2. 2...X. ...XX. XXXXX1 5 6 .XX... ..XX1. 2...X. ...XX. XXXXX.
     

    Sample Output
    It takes 13 seconds to reach the target position, let me show you the way. 1s:(0,0)->(1,0) 2s:(1,0)->(1,1) 3s:(1,1)->(2,1) 4s:(2,1)->(2,2) 5s:(2,2)->(2,3) 6s:(2,3)->(1,3) 7s:(1,3)->(1,4) 8s:FIGHT AT (1,4) 9s:FIGHT AT (1,4) 10s:(1,4)->(1,5) 11s:(1,5)->(2,5) 12s:(2,5)->(3,5) 13s:(3,5)->(4,5) FINISH It takes 14 seconds to reach the target position, let me show you the way. 1s:(0,0)->(1,0) 2s:(1,0)->(1,1) 3s:(1,1)->(2,1) 4s:(2,1)->(2,2) 5s:(2,2)->(2,3) 6s:(2,3)->(1,3) 7s:(1,3)->(1,4) 8s:FIGHT AT (1,4) 9s:FIGHT AT (1,4) 10s:(1,4)->(1,5) 11s:(1,5)->(2,5) 12s:(2,5)->(3,5) 13s:(3,5)->(4,5) 14s:FIGHT AT (4,5) FINISH God please help our poor hero. FINISH
    优先队列+BFS+记录路径

    #include <cstring>
    #include <queue>
    #include <cstdio>
    #include <iostream>
    using namespace std;
    #pragma warning(disable : 4996)
    const int MAXN = 105;
    char maps[MAXN][MAXN];
    bool visited[MAXN][MAXN];
    int moves[4][2] = {-1,0,1,0,0,-1,0,1};
    int ans, setp;
    int m, n;
    
    typedef struct Point
    {
    	int x;
    	int y;
    	int step;
    	bool operator < (const Point &p) const
    	{
    		return step > p.step;
    	}
    }Point;
    
    priority_queue<Point>Q;
    Point first[MAXN][MAXN], path[300];
    
    
    void BFS()
    {
    	while(!Q.empty())
    	{
    		Q.pop();
    	}
    	Point pre, next;
    	pre.x = n - 1;
    	pre.y = m - 1;
    	if(maps[pre.x][pre.y] >= '1' && maps[pre.x][pre.y] <= '9')
    	{
    		pre.step = maps[pre.x][pre.y] - '0';
    	}
    	else
    	{
    		pre.step = 0;
    	}
    	first[pre.x][pre.y] = pre;
    	Q.push(pre);
    	visited[n-1][m-1] = true;
    	while(!Q.empty())
    	{
    		pre = Q.top();
    		Q.pop();
    		if(pre.x == 0 && pre.y == 0) 
    		{
    			setp = pre.step;
    			return;
    		}
    		for(int i = 0; i < 4; i++)
    		{
    			next.x = pre.x + moves[i][0];
    			next.y = pre.y + moves[i][1];
    			if(next.x >= 0 &&next.x < n && next.y >= 0 && next.y < m && !visited[next.x][next.y] && maps[next.x][next.y] != 'X')
    			{
    				first[next.x][next.y] = pre;
    				visited[next.x][next.y] = true;
    				if(maps[next.x][next.y]=='.')
    				{
    					next.step = pre.step + 1;
    				}
    				else
    				{
    					next.step = pre.step + maps[next.x][next.y] - '0' + 1;
    				}
    				Q.push(next);
    			}
    		}
    	}
    }
    
    void print()
    {
    	Point pre;
    	pre.x = 0;
    	pre.y = 0;
    	int width, t;
    	t = 1;
    	for (int i = 1; i <= setp; i++)
    	{
    		path[i] = pre;
    		pre = first[pre.x][pre.y];
    	}
    	for (int i = 1; i <= setp; i++)
    	{
    		if(path[i].x == n - 1 && path[i].y == m - 1)
    		{
    			break;
    		}
    		if(maps[path[i].x][path[i].y] >= '1' && maps[path[i].x][path[i].y] <= '9')
    		{
    			width = maps[path[i].x][path[i].y] - '0';
    			while (width--)
    			{
    				printf("%ds:FIGHT AT (%d,%d)\n", t++, path[i].x, path[i].y);
    			}
    		}
    		printf("%ds:(%d,%d)->(%d,%d)\n", t++, path[i].x, path[i].y, path[i+1].x, path[i+1].y);
    	}
    	if(maps[n-1][m-1] >= '1' && maps[n-1][m-1] <= '9')
    	{
    		width = maps[n-1][m-1] - '0';
    		while (width--)
    		{
    			printf("%ds:FIGHT AT (%d,%d)\n", t++, n-1, m-1);
    		}
    	}
    }
    
    int main()
    {
    	freopen("in.txt","r",stdin);
    	while(scanf("%d %d", &n, &m) != EOF)
    	{
    		memset(first, 0, sizeof(first));
    		memset(maps, 0, sizeof(maps));
    		memset(visited, 0, sizeof(visited));
    		for(int i = 0; i < n; i++)
    		{
    			scanf("%s", maps[i]);
    		}
    		setp = -1;
    		BFS();
    		if(setp == -1)
    		{
    			printf("God please help our poor hero.\n");
    		}
    		else
    		{
    			printf("It takes %d seconds to reach the target position, let me show you the way.\n", setp);
    			print();
    		}
    		printf("FINISH\n");
    	}
    
    }




  • 相关阅读:
    第二阶段冲刺第二天
    第二阶段冲刺第一天
    学习进度表_十四周
    购买图书
    学习进度表_十三周
    寻找水王续
    学习进度表_十二周
    《梦断代码》读后笔记_4
    找水王
    学习进度表_十一周
  • 原文地址:https://www.cnblogs.com/lgh1992314/p/5834976.html
Copyright © 2011-2022 走看看