zoukankan      html  css  js  c++  java
  • poj_2352Stars

    Stars
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 25880   Accepted: 11309

    Description

    Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

    For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

    You are to write a program that will count the amounts of the stars of each level on a given map.

    Input

    The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

    Output

    The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

    Sample Input

    5
    1 1
    5 1
    7 1
    3 3
    5 5

    Sample Output

    1
    2
    1
    1
    0
    改点求段。

    #include <iostream>
    #include <cstring>
    #include <cstdio>
    using namespace std;
    
    const int MAXN = 32005;
    int tree[MAXN];
    int Level[MAXN];
    
    int LowBit(int t)
    {
    	return t&(-t);  
    }
    
    void Update(int pos, int num)
    {
    	while(pos <= MAXN)
    	{
    		tree[pos] += num;
    		pos += LowBit(pos);
    	}
    }
    
    int GetSum(int end)
    {
    	int sum = 0;
    	while(end > 0)
    	{
    		sum += tree[end];
    		end -= LowBit(end);
    	}
    	return sum;
    }
    
    int main()
    {
    	freopen("in.txt","r",stdin);
    	int n, x, y;
    	while(scanf("%d", &n) != EOF)
    	{
    		memset(tree, 0, sizeof(tree));
    		memset(Level, 0, sizeof(Level));
    		for(int i = 1;i <= n; i++)
    		{
    			scanf("%d %d", &x, &y);
    			x++;    //Update(0,1);无限循环
    			Update(x, 1);
    			Level[GetSum(x) - 1]++;
    		}
    		for(int i = 0;i < n; i++)
    			printf("%d\n", Level[i]);
    	}
    	return 0;
    }



  • 相关阅读:
    oracle数据库连接不上
    Oracle的regexp_instr函数简单用法
    Oracle中dbms_random.string 的用法
    oracle 简单输出语句与赋值
    oracle中sequence(自增序号)的用法
    oracle 函数的返回值与out参数
    SQL%ROWCOUNT作用
    100多个基础常用JS函数和语法集合大全
    题解【AcWing272】最长公共上升子序列
    题解【POJ1062】昂贵的聘礼
  • 原文地址:https://www.cnblogs.com/lgh1992314/p/5834988.html
Copyright © 2011-2022 走看看