zoukankan      html  css  js  c++  java
  • zoj_3710Friends

    Friends

    Time Limit: 2 Seconds      Memory Limit: 65536 KB

    Alice lives in the country where people like to make friends. The friendship is bidirectional and if any two person have no less than k friends in common, they will become friends in several days. Currently, there are totally n people in the country, and m friendship among them. Assume that any new friendship is made only when they have sufficient friends in common mentioned above, you are to tell how many new friendship are made after a sufficiently long time.

    Input

    There are multiple test cases.

    The first lien of the input contains an integer T (about 100) indicating the number of test cases. Then T cases follow. For each case, the first line contains three integers n, m, k (1 ≤ n ≤ 100, 0 ≤ m ≤ n×(n-1)/2, 0 ≤ k ≤ n, there will be no duplicated friendship) followed by m lines showing the current friendship. The ith friendship contains two integers ui, vi (0 ≤ ui, vi < nui ≠ vi) indicating there is friendship between person ui and vi.

    Note: The edges in test data are generated randomly.

    Output

    For each case, print one line containing the answer.

    Sample Input

    3
    4 4 2
    0 1
    0 2
    1 3
    2 3
    5 5 2
    0 1
    1 2
    2 3
    3 4
    4 0
    5 6 2
    0 1
    1 2
    2 3
    3 4
    4 0
    2 0

    Sample Output

    2
    0
    4
    
    
    STL set + map
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<map>
    #include<cmath>
    #include<vector>
    #include<algorithm>
    #include<set>
    #include<string>
    #include<queue>
    #include <stack>
    using namespace std;
    #pragma warning(disable : 4996)
    
    int main()
    {
    	freopen("in.txt", "r", stdin);
    	map<int, set<int> >Map;
    	set<int>::iterator it;
    	int t, n, m, k, x, y, ans, num, i, j;
    	bool flag;
    	scanf("%d", &t);
    	while (t--)
    	{
    		Map.clear();
    		scanf("%d %d %d", &n, &m, &k);
    		while (m--)
    		{
    			scanf("%d %d", &x, &y);
    			Map[x].insert(y);
    			Map[y].insert(x);
    		}
    		flag = true;
    		ans = 0;
    		while (flag)
    		{
    			flag = false;
    			for (i = 0; i < n; i++)
    			{
    				for (j = i + 1; j < n; j++)
    				{
    					if(Map[i].find(j) != Map[i].end())
    					{
    						continue;
    					}
    					num = 0;
    					for (it = Map[i].begin(); it != Map[i].end(); it++)
    					{
    						if(Map[j].find(*it) != Map[j].end())
    						{
    							num++;
    						}
    					}
    					if(num >= k)
    					{
    						ans++;
    						Map[i].insert(j);
    						Map[j].insert(i);
    						flag = true;
    					}
    				}
    			}
    		}
    		printf("%d\n", ans);
    	}
    	return 0;
    }
    昨天训练赛这样写就WA,想不明白
    
    
    for (it = Map[i].begin(); it != Map[i].end(); it++)
    {
    	if(Map[j].find(*it) != Map[j].end())
    	{
    		num++;
    		if(num >= k)
    		{
    			ans++;
    			flag = true;
    			Map[i].insert(j);
    			Map[j].insert(i);
    			break;
    		}
    	}
    }



  • 相关阅读:
    selenium 的页面对象模型Page Object
    PostMan的在线安装和简单使用
    用Jmeter对数据库执行压力测试
    常用的Linux系统命令
    摘:《自动化测试技术领航》
    WEB接口测试之Jmeter接口测试自动化 (四)(持续构建)
    WEB接口测试之Jmeter接口测试自动化 (二)(数据分离)
    WEB接口测试之Jmeter接口测试自动化 (一)(初次接触)
    性能测试篇 :Jmeter监控服务器性能
    UI自动化测试篇 :ReportNG替代TestNG自带html版测试报告初探
  • 原文地址:https://www.cnblogs.com/lgh1992314/p/5835011.html
Copyright © 2011-2022 走看看