zoukankan      html  css  js  c++  java
  • hdoj_4006优先队列的使用

    The kth great number

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
    Total Submission(s): 4732    Accepted Submission(s): 1941


    Problem Description
    Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.
     

    Input
    There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number. 
     

    Output
    The output consists of one integer representing the largest number of islands that all lie on one line. 
     

    Sample Input
    8 3 I 1 I 2 I 3 Q I 5 Q I 4 Q
     

    Sample Output
    1 2 3

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<map>
    #include<cmath>
    #include<vector>
    #include<algorithm>
    #include<set>
    #include<string>
    #include<queue>
    #include <stack>
    #include <functional>
    using namespace std;
    #pragma warning(disable : 4996)
    const int MAXN = 200010;
    
    int main()
    {
    	freopen("in.txt", "r", stdin);
    	priority_queue<int, vector<int>, greater<int> >Q;
    	int n, m, x;
    	char c;
    	while (scanf("%d %d", &n, &m) != EOF)
    	{
    		while (!Q.empty())
    		{
    			Q.pop();
    		}
    		while (n--)
    		{
    			getchar();
    			scanf("%c", &c);
    			if(c == 'I')
    			{
    				scanf("%d", &x);
    				Q.push(x);
    				if(Q.size() > m)
    				{
    					Q.pop();
    				}
    			}
    			else
    			{
    				printf("%d\n", Q.top());
    			}
    		}
    	}
    	return 0;
    }


  • 相关阅读:
    常用的dos命令
    定时器
    自动化工具下载地址
    Eclipse自动提示
    An error occurred: No action handlers found
    生产消费的经典案例
    SpringBoot 优雅的参数效验
    40 个 SpringBoot 常用注解
    极简入门,Shiro的认证与授权流程解析
    Java多线程批量处理、线程池的使用
  • 原文地址:https://www.cnblogs.com/lgh1992314/p/5835017.html
Copyright © 2011-2022 走看看