zoukankan      html  css  js  c++  java
  • hdoj_1251统计难题

    统计难题

    Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131070/65535 K (Java/Others)
    Total Submission(s): 12722    Accepted Submission(s): 5378


    Problem Description
    Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).
     

    Input
    输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

    注意:本题只有一组测试数据,处理到文件结束.
     

    Output
    对于每个提问,给出以该字符串为前缀的单词的数量.
     

    Sample Input
    banana band bee absolute acm ba b band abc
     

    Sample Output
    2 3 1 0

    #include<iostream>
    #include<cstdio>
    using namespace std;
    #pragma warning(disable : 4996)
    #define MAX 26
    
    typedef struct Node
    {
    	struct Node *next[MAX];
    	int v;
    }Node, *Trie;
    Trie root;
    
    void createTrie(char *str)
    {
    	int len, i, j;
    	Node *current, *newnode;
    	len = strlen(str);
    	if(len == 0)
    	{
    		return;
    	}
    	current = root;
    	for(i = 0; i < len; i++)
    	{
    		int id = str[i] - 'a';
    		if(current->next[id] == NULL)
    		{
    			newnode = (Trie)malloc(sizeof(Node));
    			newnode->v = 1;    //初始v==1
    			for(j = 0; j < MAX; j++)
    			{
    				newnode->next[j] = NULL;
    			}
    			current->next[id] = newnode;
    			current = current->next[id];
    		}
    		else
    		{
    			current->next[id]->v++;
    			current = current->next[id];
    		}
    	}
    	 //current->v = -1;   //若为结尾,则将v改成-1表示(视情况而定)
    }
    
    int findTrie(char *str)
    {
    	int i, len;
    	Trie current = root;
    	len = strlen(str);
    	if(len == 0)
    	{
    		return 0;
    	}
    	for(i = 0; i < len; i++)
    	{
    		int id = str[i] - 'a';  //根据需要选择是减去'0'还是'a',或者是'A'
    		current = current->next[id];
    		if(current == NULL)   //若为空集,表示不存以此为前缀的串
    		{
    			return 0;
    		}
    		/*if(current->v == -1)   //字符集中已有串是此串的前缀
    		{
    			return -1;
    		}*/
    	}
    	//return -1;   //此串是字符集中某串的前缀
    	return current->v;
    }
    
    void dealTrie(Trie T)
    {
    	int i;
    	if(T == NULL)
    	{
    		return;
    	}
    	for(i = 0; i < MAX; i++)
    	{
    		if(T->next[i] != NULL)
    		{
    			free(T->next[i]);
    		}
    	}
    	free(T);
    }
    
    int main()
    {
    	freopen("in.txt", "r", stdin);
    	char str[15] = {0};
    	int i;
    	root = (Trie)malloc(sizeof(Node));
    	for (i = 0; i < MAX; i++)
    	{
    		root->next[i] = NULL;
    	}
    	while (gets(str) && strcmp(str, "") != 0)
    	{
    		createTrie(str);
    	}
    	while (gets(str))
    	{
    		int ans = findTrie(str);
    		printf("%d\n", ans);
    	}
    	return 0;
    }


  • 相关阅读:
    编程浪子我的个人知识树
    JAVA基本数据类型
    JS导出数据为表格-csv
    table表格打印样式
    ENTER键指定事件
    legend生成表单边框效果
    js按拼音排序算法
    CommonJs规范
    iscroll在安卓高版本(6.0以上)某些机型上滑动卡顿问题的解决方法
    前端常见报错原因详解
  • 原文地址:https://www.cnblogs.com/lgh1992314/p/5835064.html
Copyright © 2011-2022 走看看