zoukankan      html  css  js  c++  java
  • hdoj_1856More is better(并查集)

    More is better

    Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
    Total Submission(s): 8846    Accepted Submission(s): 3303


    Problem Description
    Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

    Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
     

    Input
    The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
     

    Output
    The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 
     

    Sample Input
    4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
     

    Sample Output
    4 2

    标记个数组,记录节点的个数!

    #include<iostream>
    #include<cstdio>
    #include<map>
    #include<cstring>
    #include<cmath>
    #include<vector>
    #include<algorithm>
    #include<set>
    #include<string>
    #include<queue>
    #include <stack>
    using namespace std;
    #pragma warning(disable : 4996)
    const int MAX = 10000005;
    
    int father[MAX];
    int ranks[MAX];
    
    /* 初始化集合 */
    void Make_Set(int n)
    {
    	for(int x = 1; x <= n; x++)
    	{
    		father[x] = x;
    		ranks[x] = 1;
    	}
    }
    
    /* 查找x元素所在的集合,回溯时压缩路径 */
    int Find_Set(int x)
    {
    	if (x != father[x])
    	{
    		father[x] = Find_Set(father[x]);
    	}
    	return father[x];
    }
    
    void Union_Set(int x, int y)
    {
    	x = Find_Set(x);
    	y = Find_Set(y);
    	if (x == y) return;
    	father[x] = y;
    	ranks[y] = ranks[x] + ranks[y];
    }
    
    int main()
    {
    	freopen("in.txt", "r", stdin);
    	int n, x, y;
    	while (scanf("%d", &n) != EOF)
    	{
    		Make_Set(MAX);
    		while (n--)
    		{
    			scanf("%d %d", &x, &y);
    			Union_Set(x, y);
    		}
    		int ans = -1;
    		for(int i = 1; i <= MAX; i++)
    		{
    			if(ranks[i] > ans)
    			{
    				ans = ranks[i];
    			}
    		}
    		cout << ans << endl;
    	}
    	return 0;
    }



  • 相关阅读:
    ccr1
    与非CCR代码互操作
    ccr test
    CCR
    tpl + ccr
    TPL
    利用 Rational ClearCase ClearMake 构建高性能的企业级构建环境
    Android错误:Re-installation failed due to different application signatures
    C 单例模式
    C 工厂模式 还有其他的模式
  • 原文地址:https://www.cnblogs.com/lgh1992314/p/5835074.html
Copyright © 2011-2022 走看看