zoukankan      html  css  js  c++  java
  • hdoj_1342Lotto

    Lotto

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 1142    Accepted Submission(s): 580


    Problem Description
    In a Lotto I have ever played, one has to select 6 numbers from the set {1,2,...,49}. A popular strategy to play Lotto - although it doesn't increase your chance of winning - is to select a subset S containing k (k>6) of these 49 numbers, and then play several games with choosing numbers only from S. For example, for k=8 and S = {1,2,3,5,8,13,21,34} there are 28 possible games: [1,2,3,5,8,13], [1,2,3,5,8,21], [1,2,3,5,8,34], [1,2,3,5,13,21], ... [3,5,8,13,21,34]. 

    Your job is to write a program that reads in the number k and the set S and then prints all possible games choosing numbers only from S.
     

    Input
    The input file will contain one or more test cases. Each test case consists of one line containing several integers separated from each other by spaces. The first integer on the line will be the number k (6 < k < 13). Then k integers, specifying the set S, will follow in ascending order. Input will be terminated by a value of zero (0) for k. 
     

    Output
    For each test case, print all possible games, each game on one line. The numbers of each game have to be sorted in ascending order and separated from each other by exactly one space. The games themselves have to be sorted lexicographically, that means sorted by the lowest number first, then by the second lowest and so on, as demonstrated in the sample output below. The test cases have to be separated from each other by exactly one blank line. Do not put a blank line after the last test case. 
     

    Sample Input
    7 1 2 3 4 5 6 7 8 1 2 3 5 8 13 21 34 0
     

    Sample Output
    1 2 3 4 5 6 1 2 3 4 5 7 1 2 3 4 6 7 1 2 3 5 6 7 1 2 4 5 6 7 1 3 4 5 6 7 2 3 4 5 6 7 1 2 3 5 8 13 1 2 3 5 8 21 1 2 3 5 8 34 1 2 3 5 13 21 1 2 3 5 13 34 1 2 3 5 21 34 1 2 3 8 13 21 1 2 3 8 13 34 1 2 3 8 21 34 1 2 3 13 21 34 1 2 5 8 13 21 1 2 5 8 13 34 1 2 5 8 21 34 1 2 5 13 21 34 1 2 8 13 21 34 1 3 5 8 13 21 1 3 5 8 13 34 1 3 5 8 21 34 1 3 5 13 21 34 1 3 8 13 21 34 1 5 8 13 21 34 2 3 5 8 13 21 2 3 5 8 13 34 2 3 5 8 21 34 2 3 5 13 21 34 2 3 8 13 21 34 2 5 8 13 21 34 3 5 8 13 21 34
    #include <iostream>
    #include <cstring>
    #include <vector>
    #include <algorithm>
    using namespace std;
    #pragma warning(disable : 4996)
    int ans[15];
    int num[15];
    int n;
    
    void dfs(int current, int cnt)
    {
    	int i;
    	if(current == 6)
    	{
    		for(i = 0; i < 5; i++)
    		{
    			cout << ans[i] << " ";
    		}
    		cout << ans[5] << endl;
    	}
    	else
    	{
    		for(i = cnt; i < n; i++)
    		{
    			ans[current] = num[i];
    			dfs(current + 1, i + 1);
    		}
    	}
    }
    
    int main()
    {
    	freopen("in.txt", "r", stdin);
    	cin >> n;
    	while (n != 0)
    	{
    		for(int i = 0; i < n; i++)
    		{
    			cin >> num[i];
    		}
    		dfs(0, 0);
    		cin >> n;
    		if(n != 0)
    		{
    			cout << endl;
    		}
    	}
    }



  • 相关阅读:
    解决mysql"Access denied for user'root'@'IP地址'"问题
    SpringMVC in IDEA开发实践
    Tomcat安装笔记(on Mac)
    mysql搭建及数据迁移教程
    remove-k-digits
    hdu 4691 Front compression
    STM32的FSMC总线复用调试笔记
    spring AOP 是如何一步一步被简化的
    hdu 2871 Memory Control(伸展树splay tree)
    [置顶] Objective-C ,/,ios,/iphone开发基础:协议(protocol)
  • 原文地址:https://www.cnblogs.com/lgh1992314/p/5835112.html
Copyright © 2011-2022 走看看