zoukankan      html  css  js  c++  java
  • hdoj_1058

    Humble Numbers

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 11887    Accepted Submission(s): 5162


    Problem Description
    A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. 

    Write a program to find and print the nth element in this sequence
     

    Input
    The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
     

    Output
    For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
     

    Sample Input
    1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
     

    Sample Output
    The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.

    状态转移方程:F(n)=min(F(i)*2,F(j)*3,F(k)*5,F(m)*7)

      (n>i,j,k,m)

    特别的:

      i,j,k,m只有在本项被选中后才移动

    #include <iostream>
    #include <algorithm>
    #include <cstring>
    #include <cstdio>
    using namespace std;
    #define MAX 5850
    
    int main()
    {
    	freopen("in.txt", "r", stdin);
    	int n, i = 1, j = 1, k = 1, m = 1;
    	int dp[MAX] = {0};
    	dp[1] = 1;
    	for(int x = 2; x < MAX; x++)
    	{
    		dp[x] = min(min(dp[i] * 2, dp[j] * 3), min(dp[k] * 5, dp[m] * 7));
    		if(dp[x] == dp[i] * 2)
    		{
    			i++;
    		}
    		if(dp[x] == dp[j] * 3)
    		{
    			j++;
    		}
    		if(dp[x] == dp[k] * 5)
    		{
    			k++;
    		}
    		if(dp[x] == dp[m] * 7)
    		{
    			m++;
    		}
    	}
    	while (cin >> n)
    	{
    		if(n == 0) break;
    		int x = n % 10;
    		if(n % 100 == 11 || n % 100 == 12 || n % 100 == 13)
    		{
    			printf("The %dth humble number is %d.\n", n, dp[n]);
    		}
    		else if(x == 1)
    		{
    			printf("The %dst humble number is %d.\n", n, dp[n]);
    		}
    		else if(x == 2)
    		{
    			printf("The %dnd humble number is %d.\n", n, dp[n]);
    		}
    		else if(x == 3)
    		{
    			printf("The %drd humble number is %d.\n", n, dp[n]);
    		}
    		else
    		{
    			printf("The %dth humble number is %d.\n", n, dp[n]);
    		}
    	}
    	return 0;
    }


  • 相关阅读:
    模板方法模式
    策略模式
    代理模式
    单例模式
    工厂模式
    服务器负载过高问题分析
    支付宝APP支付开发- IOException : DerInputStream.getLength(): lengthTag=89, too big
    阿里云linux服务器挂载数据盘
    3.3.4.2选择特定行
    3.3.4.1选择所有数据
  • 原文地址:https://www.cnblogs.com/lgh1992314/p/5835138.html
Copyright © 2011-2022 走看看