zoukankan      html  css  js  c++  java
  • hdoj_1503Advanced Fruits

    Advanced Fruits

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 945    Accepted Submission(s): 450
    Special Judge


    Problem Description
    The company "21st Century Fruits" has specialized in creating new sorts of fruits by transferring genes from one fruit into the genome of another one. Most times this method doesn't work, but sometimes, in very rare cases, a new fruit emerges that tastes like a mixture between both of them. 
    A big topic of discussion inside the company is "How should the new creations be called?" A mixture between an apple and a pear could be called an apple-pear, of course, but this doesn't sound very interesting. The boss finally decides to use the shortest string that contains both names of the original fruits as sub-strings as the new name. For instance, "applear" contains "apple" and "pear" (APPLEar and apPlEAR), and there is no shorter string that has the same property. 

    A combination of a cranberry and a boysenberry would therefore be called a "boysecranberry" or a "craboysenberry", for example. 

    Your job is to write a program that computes such a shortest name for a combination of two given fruits. Your algorithm should be efficient, otherwise it is unlikely that it will execute in the alloted time for long fruit names. 
     

    Input
    Each line of the input contains two strings that represent the names of the fruits that should be combined. All names have a maximum length of 100 and only consist of alphabetic characters.

    Input is terminated by end of file. 
     

    Output
    For each test case, output the shortest name of the resulting fruit on one line. If more than one shortest name is possible, any one is acceptable.
     

    Sample Input
    apple peach ananas banana pear peach
     

    Sample Output
    appleach bananas pearch
    最长公共子序列的变型:
    #include <iostream>
    #include <cstring>
    #include <cstdio>
    using namespace std;
    
    const int MAXN = 105;
    int dp[MAXN][MAXN];
    int flag[MAXN][MAXN];
    int Hash[MAXN];
    char dest[MAXN];
    char str[MAXN];
    
    int LCS(int x, int y)
    {
    	for(int i=1;i<=x;i++)
    	{
    		for(int j=1;j<=y;j++)
    		{
    			if(dest[i-1] == str[j-1])
    			{
    				dp[i][j] = dp[i-1][j-1] + 1;
    				flag[i][j] = 0;
    			}
    			else if(dp[i-1][j] >= dp[i][j-1])
    			{
    				dp[i][j] = dp[i-1][j];
    				flag[i][j] = 1;
    			}
    			else
    			{
    				dp[i][j] = dp[i][j-1];
    				flag[i][j] = 2;
    			}
    		}
    	}
    	return dp[x][y];
    }
    
    void ShowLCS(int x, int y)
    {
    	if(x == 0 || y == 0) return;
    	if(flag[x][y] == 0)
    	{
    		ShowLCS(x-1,y-1);
    		Hash[x-1] = y - 1;
    	}
    	else if(flag[x][y] == 1)
    	{
    		ShowLCS(x-1,y);
    	}
    	else
    	{
    		ShowLCS(x,y-1);
    	}
    }
    
    int main()
    {
    	freopen("in.txt","r",stdin);
    	int i, j, dest_len, str_len;
    	while(cin>>dest>>str)
    	{
    		dest_len = strlen(dest);
    		str_len = strlen(str);
    
    		for(i=0;i<dest_len;i++)
    			dp[i][0] = 0;
    		for(j=0;j<str_len;j++)
    			dp[0][j] = 0;
    
    		memset(flag,-1,sizeof(flag));
    		LCS(dest_len,str_len);
    
    		memset(Hash,-1,sizeof(Hash));
    		ShowLCS(dest_len,str_len);
    
    		int start = 0;
    		for(i=0;i<dest_len;i++)
    		{
    			if(Hash[i] == -1)
    			{
    				cout<<dest[i];
    				continue;
    			}
    			for(j=start;j<=Hash[i];j++)
    			{
    				cout<<str[j];
    			}
    			start = Hash[i] + 1;
    		}
    		for(j=start;j<str_len;j++)
    		{
    			cout<<str[j];
    		}
    		cout<<"\n";
    	}
    	return 0;
    }


  • 相关阅读:
    vs.net2003里添加邮件发件人身份验证
    Linux下用PYTHON查找同名进程
    修改机器名后要修改IIS匿名访问用户
    [C#]使用MYSQL数据库
    JIRA OutOfMemoryErrors
    获取linux下当机堆栈
    python调用pipe
    [探讨]一次性工具软件
    GGSN
    三层交换机的作用
  • 原文地址:https://www.cnblogs.com/lgh1992314/p/5835281.html
Copyright © 2011-2022 走看看