zoukankan      html  css  js  c++  java
  • hdoj_1087Super Jumping! Jumping! Jumping!

    Super Jumping! Jumping! Jumping!

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 14209    Accepted Submission(s): 5937


    Problem Description
    Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



    The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
    Your task is to output the maximum value according to the given chessmen list.
     

    Input
    Input contains multiple test cases. Each test case is described in a line as follow:
    N value_1 value_2 …value_N 
    It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
    A test case starting with 0 terminates the input and this test case is not to be processed.
     

    Output
    For each case, print the maximum according to rules, and one line one case.
     

    Sample Input
    3 1 3 2 4 1 2 3 4 4 3 3 2 1 0
     

    Sample Output
    4 10 3
    最长上升子序列的变型,求最大的和!
    #include <iostream>
    #include <cstring>
    using namespace std;
    int arr[1005];
    int dp[1005];
    
    int main()
    {
    	freopen("in.txt","r",stdin);
    	int n,i,j;
    	while(cin>>n&&n)
    	{
    		memset(arr,0,sizeof(arr));
    		memset(dp,0,sizeof(dp));
    		for(i=1;i<=n;i++)
    		{
    			cin>>arr[i];
    			dp[i] = arr[i];
    		}
    		for(i=2;i<=n;i++)
    		{
    			for(j=1;j<i;j++)
    			{
    				if(arr[i] > arr[j] && dp[j] + arr[i] > dp[i])
    				{
    					dp[i] = dp[j] + arr[i];
    
    				}
    			}
    		}
    		int ans = dp[1];
    		for(i=1;i<=n;i++)
    		{
    			if(dp[i] > ans)
    				ans = dp[i];
    		}
    		cout<<ans<<endl;
    	}
    }


  • 相关阅读:
    gcc 使用中常用的参数及命令
    Android build system & Android.mk 规范
    ndkgdb对java/native code联合调试
    Android NDK开发指南(一) Application.mk文件
    字符编码知识:Unicode、UTF8、ASCII、GB2312等编码 及 转换
    C & C++ 中值得注意的编译,链接,调试,错误及其原因
    JNI 调用规范
    Graphic 矢量图形的区域填充与缠绕规则
    Android NDK开发指南(二)Android.mk文件
    JNI 之二 :java & c/c++ 相互通信及调用
  • 原文地址:https://www.cnblogs.com/lgh1992314/p/5835285.html
Copyright © 2011-2022 走看看