zoukankan      html  css  js  c++  java
  • hdoj_1087Super Jumping! Jumping! Jumping!

    Super Jumping! Jumping! Jumping!

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 14209    Accepted Submission(s): 5937


    Problem Description
    Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



    The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
    Your task is to output the maximum value according to the given chessmen list.
     

    Input
    Input contains multiple test cases. Each test case is described in a line as follow:
    N value_1 value_2 …value_N 
    It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
    A test case starting with 0 terminates the input and this test case is not to be processed.
     

    Output
    For each case, print the maximum according to rules, and one line one case.
     

    Sample Input
    3 1 3 2 4 1 2 3 4 4 3 3 2 1 0
     

    Sample Output
    4 10 3
    最长上升子序列的变型,求最大的和!
    #include <iostream>
    #include <cstring>
    using namespace std;
    int arr[1005];
    int dp[1005];
    
    int main()
    {
    	freopen("in.txt","r",stdin);
    	int n,i,j;
    	while(cin>>n&&n)
    	{
    		memset(arr,0,sizeof(arr));
    		memset(dp,0,sizeof(dp));
    		for(i=1;i<=n;i++)
    		{
    			cin>>arr[i];
    			dp[i] = arr[i];
    		}
    		for(i=2;i<=n;i++)
    		{
    			for(j=1;j<i;j++)
    			{
    				if(arr[i] > arr[j] && dp[j] + arr[i] > dp[i])
    				{
    					dp[i] = dp[j] + arr[i];
    
    				}
    			}
    		}
    		int ans = dp[1];
    		for(i=1;i<=n;i++)
    		{
    			if(dp[i] > ans)
    				ans = dp[i];
    		}
    		cout<<ans<<endl;
    	}
    }


  • 相关阅读:
    Android核心分析之十七电话系统之rilD
    Android核心分析之十六Android电话系统-概述篇
    Android核心分析之十五Android输入系统之输入路径详解
    Android核心分析之十四Android GWES之输入系统
    Android 核心分析之十三Android GWES之Android窗口管理
    Android 核心分析之十二Android GEWS窗口管理之基本架构原理
    Android核心分析 之十一Android GWES之消息系统
    Android核心分析 之十Android GWES之基本原理篇
    Android核心分析 之九Zygote Service
    Android 核心分析 之八Android 启动过程详解
  • 原文地址:https://www.cnblogs.com/lgh1992314/p/5835285.html
Copyright © 2011-2022 走看看