zoukankan      html  css  js  c++  java
  • POJ_1631Bridging signals

    Bridging signals
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 8577   Accepted: 4636

    Description

    'Oh no, they've done it again', cries the chief designer at the Waferland chip factory. Once more the routing designers have screwed up completely, making the signals on the chip connecting the ports of two functional blocks cross each other all over the place. At this late stage of the process, it is too expensive to redo the routing. Instead, the engineers have to bridge the signals, using the third dimension, so that no two signals cross. However, bridging is a complicated operation, and thus it is desirable to bridge as few signals as possible. The call for a computer program that finds the maximum number of signals which may be connected on the silicon surface without crossing each other, is imminent. Bearing in mind that there may be thousands of signal ports at the boundary of a functional block, the problem asks quite a lot of the programmer. Are you up to the task? 

    A typical situation is schematically depicted in figure 1. The ports of the two functional blocks are numbered from 1 to p, from top to bottom. The signal mapping is described by a permutation of the numbers 1 to p in the form of a list of p unique numbers in the range 1 to p, in which the i:th number specifies which port on the right side should be connected to the i:th port on the left side.Two signals cross if and only if the straight lines connecting the two ports of each pair do.

    Input

    On the first line of the input, there is a single positive integer n, telling the number of test scenarios to follow. Each test scenario begins with a line containing a single positive integer p < 40000, the number of ports on the two functional blocks. Then follow p lines, describing the signal mapping:On the i:th line is the port number of the block on the right side which should be connected to the i:th port of the block on the left side.

    Output

    For each test scenario, output one line containing the maximum number of signals which may be routed on the silicon surface without crossing each other.

    Sample Input

    4
    6
    4
    2
    6
    3
    1
    5
    10
    2
    3
    4
    5
    6
    7
    8
    9
    10
    1
    8
    8
    7
    6
    5
    4
    3
    2
    1
    9
    5
    8
    9
    2
    3
    1
    7
    4
    6

    Sample Output

    3
    9
    1
    4
    
    
    模板题,O(N^2)肯定超时,只能选择O(nLOGn)的。
    #include <iostream>
    #include<cstring>
    #include<cstdio>
    using namespace std;
    const int MAXN = 40005;
    int arr[MAXN];
    int dp[MAXN];
    int p;
    int bSearch(int num, int k)  
    {  
    	int low=1, high=k;  
    	while(low<=high)  
    	{  
    		int mid=(low+high)/2;  
    		if(num>=dp[mid])  
    			low=mid+1;  
    		else   
    			high=mid-1;  
    	}  
    	return low;  
    }  
    
    int LIS()
    {
    	int k = 1;
    	dp[1] = arr[1];
    	for(int i=2; i<=p; ++i)
    	{
    		if(arr[i]>=dp[k])
    			dp[++k] = arr[i];
    		else
    		{
    			int pos = bSearch(arr[i], k);
    			dp[pos] = arr[i];
    		}
    	}
    	return k;
    }
    
    int main()
    {
    	freopen("in.txt","r",stdin);
    	int n;
    	scanf("%d",&n);
    	while(n--)
    	{
    		memset(arr,0,sizeof(arr));
    		scanf("%d",&p);
    		for(int i=1;i<=p;i++)
    		{
    			scanf("%d",&arr[i]);
    		}
    		printf("%d\n",LIS());
    	}
    }


  • 相关阅读:
    <area> 标签
    商务通关闭效果
    利用HTML5云存储实现模拟对比投票效果
    织梦dedecms 用交叉栏目时arclist标签调用不出内容文章的问题(纯转载)
    PHP的类文件自动加载机制
    phpStorm中git使用
    php中namespace use用法实例分析
    Git常用命令
    PHP服务器端API原理及示例(接口开发)
    聊聊 PHP 与手机 APP 开发(API 接口开发)
  • 原文地址:https://www.cnblogs.com/lgh1992314/p/5835296.html
Copyright © 2011-2022 走看看