zoukankan      html  css  js  c++  java
  • hdoj_2141

    Can you find it?

    Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/10000 K (Java/Others)
    Total Submission(s): 6083    Accepted Submission(s): 1585


    Problem Description
    Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
     

    Input
    There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
     

    Output
    For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
     

    Sample Input
    3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
     

    Sample Output
    Case 1: NO YES NO
    二分水题,开始没有预先保存a[i]+b[j],wa。也算是个小小的优化吧
    #include <iostream>
    #include <cstdio>
    #include <algorithm>
    using namespace std;
    
    int main()
    {
    	freopen("in.txt","r",stdin);
    	int a[505],b[505],c[505],sum[250050];
    	int l,n,m,s,i,x,j;
    	int ans = 0;
    	int cnt = 1;
    	int k = 0;
    	while(scanf("%d %d %d",&l,&n,&m)!=EOF)
    	{
    		memset(a,0,sizeof(a));
    		memset(b,0,sizeof(b));
    		memset(c,0,sizeof(c));
    		memset(sum,0,sizeof(sum));
    		for(i=0;i<l;i++)
    			scanf("%d",&a[i]);
    		for(i=0;i<n;i++)
    			scanf("%d",&b[i]);
    		for(i=0;i<m;i++)
    			scanf("%d",&c[i]);
    		k = 0;
    		for(i=0;i<l;i++)
    		{
    			for(j=0;j<n;j++)
    			{
    				sum[k++] = a[i] + b[j];
    			}
    		}
    		sort(sum,sum+k);
    		sort(c,c+m);
    		scanf("%d",&s);
    		printf("Case %d:\n",cnt++);
    		while(s--)
    		{
    			ans = 0;
    			scanf("%d",&x);
    			for(i=0;i<m;i++)
    			{
    				int left = 0;
    				int right = l * n - 1;
    				while(left<=right)
    				{
    					int mid = (left + right) / 2;
    					if(sum[mid] + c[i] > x)
    					{
    						right = mid - 1;
    					}
    					else if(sum[mid] + c[i] < x)
    					{
    						left = mid + 1;
    					}
    					else 
    					{
    						printf("YES\n");
    						ans = 1;
    						break;
    					}
    				}
    				if(ans==1) break;
    			}
    			if(ans==0) printf("NO\n");
    		}
    	}
    	return 0;
    }
    


  • 相关阅读:
    布隆过滤器(Bloom Filter)详解
    css-鼠标经过图片效果
    css-卡牌反转(两个内容)
    wow 属性
    小常识
    裁剪图片
    js电梯导航效果
    banner缓慢缩小过渡效果
    css——鼠标经过按钮时样式
    redis面试题redis的lru算法实现到手写lru算法
  • 原文地址:https://www.cnblogs.com/lgh1992314/p/5835333.html
Copyright © 2011-2022 走看看