zoukankan      html  css  js  c++  java
  • zoj_3203Light Bulb

    Light Bulb
    http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3203


    Time Limit: 1 Second      Memory Limit: 32768 KB

    Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.

    Input

    The first line of the input contains an integer T (T <= 100), indicating the number of cases.

    Each test case contains three real numbers Hh and D in one line. H is the height of the light bulb while h is the height of mildleopard. D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.

    Output

    For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

    Sample Input

    3
    2 1 0.5
    2 0.5 3
    4 3 4
    

    Sample Output

    1.000
    0.750
    4.000
    
    
    
    
    如图,人左右走动,求影子L的最长长度。
    根据图,很容易发现当灯,人的头部和墙角成一条直线时(假设此时人站在A点),此时的长度是影子全在地上的最长长度。当人再向右走时,影子开始投影到墙上,当人贴着墙,影子长度即为人的高度。所以当人从A点走到墙,函数是先递增再递减,为凸性函数,所以我们可以用三分法来求解。
    
    
    #include <iostream>
    #include <cstdio>
    using namespace std;
    
    double D,H,h;
    const double EPS = 1e-10;
    
    double Cal(double L)
    {
    	return D * (h - L) / (H - L) + L;
    }
    
    double Solve(void)
    {
    	double Left, Right;
    	double mid, midmid;
    	double mid_value, midmid_value;
    	Left = 0; Right = h;
    	while (Left + EPS < Right)
    	{
    		mid = (Left + Right) / 2;
    		midmid = (mid + Right) / 2;
    		mid_value = Cal(mid);
    		midmid_value = Cal(midmid);
    		if (mid_value >= midmid_value) Right = midmid;
    		else Left = mid;
    	}
    	return Left;
    }
    
    int main()
    {
    	freopen("in.txt","r",stdin);
    	int t;
    	cin>>t;
    	while(t--)
    	{
    		cin>>H>>h>>D;
    		printf("%.3lf\n",Cal(Solve()));
    	}
    }


  • 相关阅读:
    C++ Tr1中的正則表達式
    html中#include file的使用方法
    InstallShield12豪华版破解版下载|InstallShield下载|软件打包工具
    linux-多线程
    使用 ArcGIS Online和APP进行监控操作和数据采集
    西藏印象:时光篇
    西藏印象:夜色篇
    西藏印象:蓝白篇
    hex2bin
    使用openssl的aes各种加密算法
  • 原文地址:https://www.cnblogs.com/lgh1992314/p/5835345.html
Copyright © 2011-2022 走看看