zoukankan      html  css  js  c++  java
  • Little Bird

    Little Bird

    题目描述

     

    In the Byteotian Line Forest there are   trees in a row. On top of the first one, there is a little bird who would like to fly over to the top of the last tree. Being in fact very little, the bird might lack the strength to fly there without any stop. If the bird is sitting on top of the tree no.  , then in a single flight leg it can fly to any of the trees no.i+1,i+2…I+K, and then has to rest afterward.

    Moreover, flying up is far harder to flying down. A flight leg is tiresome if it ends in a tree at least as high as the one where is started. Otherwise the flight leg is not tiresome.

    The goal is to select the trees on which the little bird will land so that the overall flight is least tiresome, i.e., it has the minimum number of tiresome legs. We note that birds are social creatures, and our bird has a few bird-friends who would also like to get from the first tree to the last one. The stamina of all the birds varies, so the bird's friends may have different values of the parameter  . Help all the birds, little and big!

    有一排n棵树,第i棵树的高度是Di。

    MHY要从第一棵树到第n棵树去找他的妹子玩。

    如果MHY在第i棵树,那么他可以跳到第i+1,i+2,...,i+k棵树。

    如果MHY跳到一棵不矮于当前树的树,那么他的劳累值会+1,否则不会。

     

    为了有体力和妹子玩,MHY要最小化劳累值。

     

     

    输入

     

    There is a single integer N(2<=N<=1 000 000) in the first line of the standard input: the number of trees in theByteotian Line Forest. The second line of input holds   integers D1,D2…Dn(1<=Di<=10^9) separated by single spaces: Di is the height of the i-th tree.

     

    The third line of the input holds a single integer Q(1<=Q<=25): the number of birds whose flights need to be planned. The following Q lines describe these birds: in the i-th of these lines, there is an integer Ki(1<=Ki<=N-1) specifying the i-th bird's stamina. In other words, the maximum number of trees that the i-th bird can pass before it has to rest is Ki-1.

     

     

    输出

     

    Your program should print exactly Q lines to the standard output. In the I-th line, it should specify the minimum number of tiresome flight legs of the i-th bird.

     

     

    样例输入

    9
    4 6 3 6 3 7 2 6 5
    2
    2
    5

    样例输出

    2
    1

    提示

     

     

    Explanation: The first bird may stop at the trees no. 1, 3, 5, 7, 8, 9. Its tiresome flight legs will be the one from the 3-rd tree to the 5-th one and from the 7-th to the 8-th.

     

     

    来源

    poi2014

    solution

    考虑DP

    f[i]=f[j](h[i]<h[j]),f[j]+1(h[i]>=h[j])

    用队列优化

    如果f[r]>f[i] 或者 f[r]==f[i]&&s[r]<=s[i] 就r--

    if(f[i]<f[q[r]]&&r>=l)r--;
    if(s[q[r]]<=s[i]&&f[i]==f[q[r]]&&r>=l)r--;

    这样WA

    while(f[i]<=f[q[r]]&&l<=r){
        if(f[i]==f[q[r]]&&s[i]<s[q[r]]) break;
        r--;
    }

    这样A

    个人觉得应该是有一段相等的出现在小于的后面。

    #include<cstdio>
    #include<iostream>
    #include<cstdlib>
    #include<cstring>
    #include<algorithm>
    #include<cmath>
    #define maxn 1000005
    using namespace std;
    int n,s[maxn],q[maxn],f[maxn],Q,k,l,r;
    int main()
    {
    	cin>>n;
    	for(int i=1;i<=n;i++)scanf("%d",&s[i]);
    	cin>>Q;
    	while(Q--){
    		cin>>k;
    		memset(f,0,sizeof f);
    		memset(q,0,sizeof q);
    		l=1,r=1;q[l]=1;
    		for(int i=2;i<=n;i++){
    			while(i-q[l]>k&&l<r)l++;
    			if(s[i]>=s[q[l]]){
    				f[i]=f[q[l]]+1;
    				//cout<<i<<' '<<q[l]<<endl;
    			}
    			else f[i]=f[q[l]];
    			while(f[i]<=f[q[r]]&&l<=r){
                    if(f[i]==f[q[r]]&&s[i]<s[q[r]]) break;
                    r--;
                }
    			q[++r]=i;
    		}
    		cout<<f[n]<<endl;
    	}
    	return 0;
    }
    
  • 相关阅读:
    Windows下Android开发环境搭建
    解决Win7下打开或关闭Windows功能空白一片
    C#中得到程序当前工作目录和执行目录的一些方法
    创业者必看的小故事
    Sql Server 2005外围应用应用配置器打不开了怎么办
    vs2005无法Web调试
    SQL Server 全局变量
    转 document.documentElement与document.body
    [转]使用SSMA将Oracle数据库转成SQL Server 2008
    Delphi 2009、C++Builder2009正式发布
  • 原文地址:https://www.cnblogs.com/liankewei/p/10358864.html
Copyright © 2011-2022 走看看