zoukankan      html  css  js  c++  java
  • ACM HDU 1017 A Mathematical Curiosity

    A Mathematical Curiosity

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 17031    Accepted Submission(s): 5306


    Problem Description
    Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

    This problem contains multiple test cases!

    The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

    The output format consists of N output blocks. There is a blank line between output blocks.
     
    Input
    You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.
    Output
    For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.
    Sample Input
    1
    10 1
    20 3
    30 4
    0 0
    Sample Output
    Case 1: 2
    Case 2: 4
    Case 3: 5
    Source
     
    Recommend
    JGShining
     
     
    #include<stdio.h>
    int main()
    {
        int n, m, times, count = 0, i, j, flag = 1;
        scanf("%d", &times);
        while(times--)
        {
            while(1)
            {
                scanf("%d%d", &n, &m);
                if(!n && !m) break;
                for(i=1; i<n; ++i)
                for(j=1; j<i; ++j)
                if((i*i+j*j+m)%(i*j) == 0) count++;
                printf("Case %d: %d\n", flag++, count);
                count = 0;
            }
            flag = 1;
            if(times != 0) printf("\n");
        }
        
    return 0;
    }

    解题报告:

    这题明显的水题,之所以会PE,我不会承认是我的错,只是把N跟第一组 input 之间的 Blank 忽略掉就没问题了。

    物役记

    更多内容请关注个人微信公众号 物役记 (微信号:materialchains)

  • 相关阅读:
    springCloud学习6(Spring Cloud Sleuth 分布式跟踪)
    springCloud学习5(Spring-Cloud-Stream事件驱动)
    springCloud学习4(Zuul服务路由)
    springCloud学习3(Netflix Hystrix弹性客户端)
    springCloud学习笔记2(服务发现)
    EFCore
    webBrowser.DocumentText重新赋值无效解决方法
    C# SQLite写入和读取DateTime类型
    自定义协议链接 ------2.实践篇
    自定义协议链接 ------1.原理篇
  • 原文地址:https://www.cnblogs.com/liaoguifa/p/2713095.html
Copyright © 2011-2022 走看看