zoukankan      html  css  js  c++  java
  • HDU ACM 1097 Hard Puzzle

    A hard puzzle

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 19595    Accepted Submission(s): 7003

    Problem Description
    lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
    this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.
    Input
    There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)
    Output
    For each test case, you should output the a^b's last digit number.
    Sample Input
    7 66
    8 800
    Sample Output
    9
    6
    Author
    eddy
    Recommend
    JGShining
     
     AC代码:
    #include<stdio.h>
    #include<string.h>
    int temp[100];
    int main()
    {
        long i, n = 1, m;
        long long a, c;
        while(scanf("%lld%lld", &a, &c) != EOF)
        {
            memset(temp, 0, sizeof(temp));
            temp[0] = a%10;
            for(i=1; i<100; i++)
            {
                if((temp[i] = (temp[0]*temp[i-1])%10) == temp[0]) break;
    
            }
            printf("%d\n", temp[(c-1)%i]);
        }
        return 0;
    }

    结题报告:

    实话实说,很久没编程的感觉就连ACM Step中简单的题目都忘了如何做了,似乎以前做过的题今天拿出来好似未曾相见。WA了差不多一个晚上,弄坏了心情最后什么都做不了!

    本是不属于这一路的人,当初的选择没说过要后悔!

     
    物役记

    更多内容请关注个人微信公众号 物役记 (微信号:materialchains)

  • 相关阅读:
    中国气象局所有城市代码
    Android项目源码混淆问题解决方法
    跳转到系统默认的Home
    jsp四个属性范围的比较
    response内置对象学习
    jsp登陆程序实现
    request内置对象学习
    JavaBean的学习
    android编程中的琐碎知识点汇总(5)
    android编程中的琐碎知识点汇总(4)
  • 原文地址:https://www.cnblogs.com/liaoguifa/p/2732010.html
Copyright © 2011-2022 走看看