zoukankan      html  css  js  c++  java
  • HDU ACM 1009 FatMouse' Trade

    FatMouse' Trade

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 26437    Accepted Submission(s): 8487

    Problem Description
    FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
    The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
     
    Input
    The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
    Output
    For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
     
    Sample Input
    5 3
    7 2
    4 3
    5 2
    20 3
    25 18
    24 15
    15 10
    -1 -1
     
    Sample Output
    13.333
    31.500
     
    Author
    CHEN, Yue
     
    Source
     
    Recommend
    JGShining
     
    #include<stdio.h>
    #include<string.h>
    int J[1002], F[1002];
    double JF[1002];
    int main()
    {
        int j, m, n, i;
        double sum, temp;
        while(scanf("%d%d", &m, &n) != EOF && m != -1 && n != -1)
        {
            memset(J, 0, sizeof(J));
            memset(F, 0, sizeof(F));
            memset(JF,0, sizeof(JF));
            for(i=1; i<=n; ++i)  //从1开始 
            {
                scanf("%d%d", &J[i], &F[i]);
                JF[i] = J[i]*1.0/F[i];
            }
    
            for(i=2; i<=n; ++i)
            {
                if(JF[i] >= JF[i-1])
                {
                    JF[0] = JF[i];
                    J[0] = J[i];
                    F[0] = F[i];
                    
                    JF[i] = JF[i-1];
                    J[i] = J[i-1];
                    F[i] = F[i-1];                
                    
                    for(j=i-2; j>=0; --j)
                    {
                        if(JF[0] >= JF[j])
                        {
                            JF[j+1] = JF[j];
                            J[j+1] = J[j];
                            F[j+1] = F[j];                        
                        }
                        else {
                                JF[j+1] = JF[0]; 
                                J[j+1] = J[0]; 
                                F[j+1] = F[0]; 
                                break;
                            }
                    }
                }
             } 
                      
             sum = 0;
             temp = m;
             for(i=1; i<=n; ++i)
             {
                 temp = temp - F[i];
                 if(temp >= 0) sum = sum + 1.0*J[i];
                 else {sum = sum + (temp + F[i])*JF[i]; break;} 
                
             }
             printf("%.3f\n", sum);
            
            
        }   
        return 0; 
    }

    结题报告:

    1AC的感觉确实比较好,但是到底是因为什么才AC的,我却不知道怎么回答,天知道提交之后会有什么后果,我只知道有人告诉我这题耐心做还是很容易做出来的,所以就顺理成章的耐心地做出来了,还好,让我知道了耐心、坚持、自信的重要性。

    肥老鼠换东西,比率a%就要看你给那只猫多好了,对于每一个房间,给你的提成或者说利润=J[i]/F[i], 所以刚开始就要计算各房间的利润然后排序,然后问你了:你会将钱投资给利润高的还是利润低的?

     
  • 相关阅读:
    MyBatis学习教程
    【转载】Spring MVC 整合 Freemarker
    Java高效编程之四【C语言结构的替代】
    String相关的问题
    接口与抽象类的区别
    Java Garbage Collection基础详解------Java 垃圾回收机制技术详解
    数据库事物、隔离等级及数据库锁机制
    hadoop 多表join:Map side join及Reduce side join范例
    Java IO设计模式彻底分析 (转载)
    傅里叶变换的智慧[转]
  • 原文地址:https://www.cnblogs.com/liaoguifa/p/2745712.html
Copyright © 2011-2022 走看看