zoukankan      html  css  js  c++  java
  • Uva 409 Excuses, Excuses!

     Excuses, Excuses! 

      Time limit: 3.000 seconds

     

    Judge Ito is having a problem with people subpoenaed for jury duty giving rather lame excuses in order to avoid serving. In order to reduce the amount of time required listening to goofy excuses, Judge Ito has asked that you write a program that will search for a list of keywords in a list of excuses identifying lame excuses. Keywords can be matched in an excuse regardless of case.

    Input

    Input to your program will consist of multiple sets of data.

    • Line 1 of each set will contain exactly two integers. The first number ( tex2html_wrap_inline30 ) defines the number of keywords to be used in the search. The second number ( tex2html_wrap_inline32 ) defines the number of excuses in the set to be searched.
    • Lines 2 through K+1 each contain exactly one keyword.
    • Lines K+2 through K+1+E each contain exactly one excuse.
    • All keywords in the keyword list will contain only contiguous lower case alphabetic characters of length L ( tex2html_wrap_inline42 ) and will occupy columns 1 through L in the input line.
    • All excuses can contain any upper or lower case alphanumeric character, a space, or any of the following punctuation marks [SPMamp".,!?&] not including the square brackets and will not exceed 70 characters in length.
    • Excuses will contain at least 1 non-space character.

    Output

    For each input set, you are to print the worst excuse(s) from the list.

    • The worst excuse(s) is/are defined as the excuse(s) which contains the largest number of incidences of keywords.
    • If a keyword occurs more than once in an excuse, each occurrance is considered a separate incidence.
    • A keyword ``occurs" in an excuse if and only if it exists in the string in contiguous form and is delimited by the beginning or end of the line or any non-alphabetic character or a space.

    For each set of input, you are to print a single line with the number of the set immediately after the string ``Excuse Set #". (See the Sample Output). The following line(s) is/are to contain the worst excuse(s) one per line exactly as read in. If there is more than one worst excuse, you may print them in any order.

    After each set of output, you should print a blank line.

    Sample Input

    5 3
    dog
    ate
    homework
    canary
    died
    My dog ate my homework.
    Can you believe my dog died after eating my canary... AND MY HOMEWORK?
    This excuse is so good that it contain 0 keywords.
    6 5
    superhighway
    crazy
    thermonuclear
    bedroom
    war
    building
    I am having a superhighway built in my bedroom.
    I am actually crazy.
    1234567890.....,,,,,0987654321?????!!!!!!
    There was a thermonuclear war!
    I ate my dog, my canary, and my homework ... note outdated keywords?

    Sample Output

    Excuse Set #1
    Can you believe my dog died after eating my canary... AND MY HOMEWORK?
    
    Excuse Set #2
    I am having a superhighway built in my bedroom.
    There was a thermonuclear war!


    #include<stdio.h>
    #include<string.h>
    #include<ctype.h>
    typedef struct{
        int sort, data;
    }final;
    
    int main()
    {
        final H[22];
        int i, j, len, e, k, keylen, loc, flag, T=0;
        char keyword[22][22], excuse[22][74], temp[22][74], *str;
        while(scanf("%d%d", &k, &e) != EOF)
        {
            T++;
            
            for(i=0; i<22; ++i)
            {
                H[i].sort = i, H[i].data = 0;
                memset(keyword[i], '\0', sizeof(char)*22);
                memset(excuse[i], '\0', sizeof(char)*74);
                memset(temp[i], '\0', sizeof(char)*74); 
            }
            for(i=0; i<k; ++i)
            scanf("%s", keyword[i]);
            getchar(); 
            for(i=0; i<e; ++i)
            {
                fgets(temp[i], 74, stdin);
                len = strlen(temp[i]);
                if(temp[i][len-1] != '\n') temp[i][len++] = '\n';
                for(j=0; j<len; ++j)
                if(isalpha(temp[i][j]) && isupper(temp[i][j])) excuse[i][j] = tolower(temp[i][j]);
                else excuse[i][j] = temp[i][j];
                for(j=0; j<k; ++j)
                {
                    if((str = strstr(excuse[i], keyword[j])) != NULL)
                    {
                        loc = str - excuse[i];
                        keylen = strlen(keyword[j]);
                        if(!loc && !isalpha(excuse[i][keylen])) H[i].data++;
                        else if(!isalpha(excuse[i][loc-1]) && !isalpha(excuse[i][keylen+loc])) H[i].data++;
                    }
                }
            }
            
            for(i=0; i<e-1; ++i)
            {
                keylen = 1;
                for(j=0; j<e-1-i; ++j)
                {
                    if(H[j].data < H[j+1].data)
                    {
                        keylen = 0;
                        flag = H[j].sort;
                        H[j].sort = H[j+1].sort;
                        H[j+1].sort = flag;
                        flag = H[j].data;
                        H[j].data = H[j+1].data;
                        H[j+1].data = flag;
                    }
                }
                if(keylen) break;
            }
            
            
            
            printf("Excuse Set #%d\n", T);
            printf("%s", temp[H[0].sort]);
            for(i=1; i<e; ++i)
            {
                if(H[i].data == H[0].data) printf("%s", temp[H[i].sort]);
                else break;
            }
            printf("\n");
            
        }
        return 0;
    }

    解题报告:

    对于一个excuse,查找里面的keywords用strstr函数,判断此keyword在excuse里前后的位置是怎样的,然后进行判断,其实就是让人相信keyword左右两边的字符不是isalpha而已。

    痛心的不是WA,再多的WA如果值得,为何不可呢?

  • 相关阅读:
    重构手法之简化函数调用【5】
    netstat命令
    Python使用wxpy模块实现微信两两群组消息同步
    format函数格式化显示的方法
    scrapy介绍及使用
    Linux常用命令复习
    Django实现博客项目
    Django中CKEditor富文本编译器的使用
    Django-admin站点管理的详细使用
    电脑修改密码后,git push 报错unable to access
  • 原文地址:https://www.cnblogs.com/liaoguifa/p/2790315.html
Copyright © 2011-2022 走看看