zoukankan      html  css  js  c++  java
  • HDU ACM 1213 How Many Tables(UFS)

    How Many Tables

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 7430    Accepted Submission(s): 3574


    Problem Description
    Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

    One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

    For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
     
    Input
    The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
     
    Output
    For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
     
    Sample Input
    2 5 3 1 2 2 3 4 5 5 1 2 5
     
    Sample Output
    2 4
     
    Author
    Ignatius.L
     
    Source
     
    Recommend
    Eddy
     
    #include<stdio.h>
    #include<string.h>
    int father[1002];
    
    int find(int n)
    {
        if(father[n] == n) return n;
        else return father[n] = find(father[n]);
    }
    
    int main()
    {
        int n, m, T, x, y, cnt, i, j;
        scanf("%d", &T);
        while(T--)
        {
            cnt = 0;
            scanf("%d%d", &n, &m);
            for(i=0; i<n; ++i) father[i] = i;
            for(i=0; i<m; ++i) 
            {
                scanf("%d%d", &x, &y);
                x = find(x-1), y = find(y-1);
                if(x != y) father[x] = y;
            }
            for(i=0; i<n; ++i) if(father[i] == i) cnt++;
            printf("%d\n", cnt);
        }
        return 0;
    }
  • 相关阅读:
    判断是否在可视区域
    格式化数字10000,为10,000
    把数组(含有30项分成5组)
    排序
    enzyme 学习一
    golang使用sftp连接服务器远程上传、下载文件
    golang使用ssh远程连接服务器并执行命令
    一文弄懂vlan、三层交换机、网关、DNS、子网掩码、MAC地址的含义
    golang的序列化与反序列化的几种方式
    golang命令行参数解析
  • 原文地址:https://www.cnblogs.com/liaoguifa/p/2821690.html
Copyright © 2011-2022 走看看