zoukankan      html  css  js  c++  java
  • HDU ACM 1272 小希的迷宫

    小希的迷宫

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 16163    Accepted Submission(s): 4946


    Problem Description
    上次Gardon的迷宫城堡小希玩了很久(见Problem B),现在她也想设计一个迷宫让Gardon来走。但是她设计迷宫的思路不一样,首先她认为所有的通道都应该是双向连通的,就是说如果有一个通道连通了房间A和B,那么既可以通过它从房间A走到房间B,也可以通过它从房间B走到房间A,为了提高难度,小希希望任意两个房间有且仅有一条路径可以相通(除非走了回头路)。小希现在把她的设计图给你,让你帮忙判断她的设计图是否符合她的设计思路。比如下面的例子,前两个是符合条件的,但是最后一个却有两种方法从5到达8。 
     
    Input
    输入包含多组数据,每组数据是一个以0 0结尾的整数对列表,表示了一条通道连接的两个房间的编号。房间的编号至少为1,且不超过100000。每两组数据之间有一个空行。 
    整个文件以两个-1结尾。
     
    Output
    对于输入的每一组数据,输出仅包括一行。如果该迷宫符合小希的思路,那么输出"Yes",否则输出"No"。
     
    Sample Input
    6 8 5 3 5 2 6 4 5 6 0 0 8 1 7 3 6 2 8 9 7 5 7 4 7 8 7 6 0 0 3 8 6 8 6 4 5 3 5 6 5 2 0 0 -1 -1
     
    Sample Output
    Yes Yes No
     
    Author
    Gardon
     
    Source
     
    Recommend
    lxj
     
    #include<stdio.h>
    #include<string.h>
    #define MAXN 100002
    int father[MAXN];
    int record[MAXN];
    
    int InitUnion()
    {
        int i;
        for(i=0; i<MAXN; ++i)
        {
            father[i] = i;
            record[i] = 0;
        }
    }
    
    int find_set(n)
    {// 改成递归的形式<->爆栈 
        
            while(father[n] != n)
            {
                n = father[n];
            }
            return n;
    }
    
    int main()
    {
        int x, y, i, a, b, max=-1, flag = 0, cnt = 1, t;
        InitUnion();
        while(scanf("%d%d", &a, &b) == 2 && a != -1 && b != -1)
        {
            if(!a && !b)
            {
                if(cnt == 1)
                printf("Yes\n");
                else
                {
                    if(flag) printf("No\n");
                    else 
                    {
                        for(i=0, t=0; i<=max; ++i)
                        if(record[i] && father[i] == i) t++;
                        if(t > 1) flag = 1;
                        if(!flag) printf("Yes\n");
                        else printf("No\n");
                    }
                    InitUnion();
                    cnt = 1, flag = 0;
                    max = -1;
                }
                continue;
            }
            a--, b--;
            cnt = 2;
            max = max > b ? max : b;
            max = max > a ? max : a;
            record[a] = record[b] = 1;
            x = find_set(a), y = find_set(b);
            if(x == y) flag = 1;
            else father[x] = y; 
        }
        return 0;
    }
  • 相关阅读:
    洛谷【P1109 学生分组】 题解
    卡特兰数
    并查集
    深度优先搜索DFS;递归
    【71】序列模型和注意力机制
    c/c++ 常用的几个安全函数
    win32 Ui 编程 收集
    vc获取特殊路径(SpecialFolder)
    std::map 自定义排序
    16-----BBS论坛
  • 原文地址:https://www.cnblogs.com/liaoguifa/p/2828670.html
Copyright © 2011-2022 走看看