zoukankan      html  css  js  c++  java
  • Uva 400 Unix ls

    Unix ls 

    The computer company you work for is introducing a brand new computer line and is developing a new Unix-like operating system to be introduced along with the new computer. Your assignment is to write the formatter for the ls function.

    Your program will eventually read input from a pipe (although for now your program will read from the input file). Input to your program will consist of a list of (F) filenames that you will sort (ascending based on the ASCII character values) and format into (C) columns based on the length (L) of the longest filename. Filenames will be between 1 and 60 (inclusive) characters in length and will be formatted into left-justified columns. The rightmost column will be the width of the longest filename and all other columns will be the width of the longest filename plus 2. There will be as many columns as will fit in 60 characters. Your program should use as few rows (R) as possible with rows being filled to capacity from left to right.

    Input

    The input file will contain an indefinite number of lists of filenames. Each list will begin with a line containing a single integer ( tex2html_wrap_inline41 ). There will then be N lines each containing one left-justified filename and the entire line's contents (between 1 and 60 characters) are considered to be part of the filename. Allowable characters are alphanumeric (a to zA to Z, and 0 to 9) and from the following set { ._- } (not including the curly braces). There will be no illegal characters in any of the filenames and no line will be completely empty.

    Immediately following the last filename will be the N for the next set or the end of file. You should read and format all sets in the input file.

    Output

    For each set of filenames you should print a line of exactly 60 dashes (-) followed by the formatted columns of filenames. The sorted filenames 1 to R will be listed down column 1; filenames R+1 to 2R listed down column 2; etc.

    Sample Input

    10
    tiny
    2short4me
    very_long_file_name
    shorter
    size-1
    size2
    size3
    much_longer_name
    12345678.123
    mid_size_name
    12
    Weaser
    Alfalfa
    Stimey
    Buckwheat
    Porky
    Joe
    Darla
    Cotton
    Butch
    Froggy
    Mrs_Crabapple
    P.D.
    19
    Mr._French
    Jody
    Buffy
    Sissy
    Keith
    Danny
    Lori
    Chris
    Shirley
    Marsha
    Jan
    Cindy
    Carol
    Mike
    Greg
    Peter
    Bobby
    Alice
    Ruben

    Sample Output

    ------------------------------------------------------------
    12345678.123         size-1               
    2short4me            size2                
    mid_size_name        size3                
    much_longer_name     tiny                 
    shorter              very_long_file_name  
    ------------------------------------------------------------
    Alfalfa        Cotton         Joe            Porky          
    Buckwheat      Darla          Mrs_Crabapple  Stimey         
    Butch          Froggy         P.D.           Weaser         
    ------------------------------------------------------------
    Alice       Chris       Jan         Marsha      Ruben       
    Bobby       Cindy       Jody        Mike        Shirley     
    Buffy       Danny       Keith       Mr._French  Sissy       
    Carol       Greg        Lori        Peter


    #include<stdio.h>
    #include<string.h>
    #include<math.h>
    char list[200][100];
    
    int minusline(int len)
    {//计算需要多少列,函数返回列数 
        double minus = len+2;
        int n;
        n = (int)floor(62*1.0/minus);
        return n;
    }
    
    int main()
    {
        int i, j, len, k, n, m, flag, longest, row, column, T=0;
        char temp[100];
        while(scanf("%d", &n) != EOF)
        {
            if(T++ != 0) printf("\n");
            for(i=0,longest=0; i<n; ++i)
            {
                scanf("%s", temp);
                len =strlen(temp);  // 计算最长字符串的长度 
                if(len > longest) longest = len;
                strcpy(list[i], temp);
            }
            
            for(i=0; i<n-1; i++)
            {// 排序 
                flag = 1;
                for(j=0; j<n-1-i; ++j)
                {
                    if(strcmp(list[j], list[j+1]) > 0)
                    {
                        strcpy(temp, list[j]);
                        strcpy(list[j], list[j+1]);
                        strcpy(list[j+1], temp);
                        flag = 0;
                    }
                }
                if(flag) break;
            }
            
            column = minusline(longest);
            for(i=0; i<60; i++) printf("-");
            printf("\n");
            row = n%column ? n/column+1 : n/column; // 计算行数 
    
            for(i=0; i<row; ++i)
            {
                for(j=0; j<column; ++j)
                {
                    if(i+row*j >= n) break;
                    printf("%s", list[i+row*j]);
                    // 纠结于空格的输出 
                    m = j != column-1 ? 2 : 0;
                    len = strlen(list[i+row*j]);
                    for(k=0; k<longest-len+m; ++k)
                    printf(" ");
                }
                if(i != row-1) printf("\n");
            }
        }
        return 0;
    }

    解题报告:

    题目的说明跟Sample Output并不符合,AC得到的结果如下:

    ------------------------------------------------------------
    12345678.123         size-1               
    2short4me            size2                
    mid_size_name        size3                
    much_longer_name     tiny                 
    shorter              very_long_file_name  
    ------------------------------------------------------------
    Alfalfa        Cotton         Joe            Porky          
    Buckwheat      Darla          Mrs_Crabapple  Stimey         
    Butch          Froggy         P.D.           Weaser         
    ------------------------------------------------------------
    Alice       Chris       Jan         Marsha      Ruben       
    Bobby       Cindy       Jody        Mike        Shirley     
    Buffy       Danny       Keith       Mr._French  Sissy       
    Carol       Greg        Lori        Peter       


  • 相关阅读:
    漫谈C语言结构体
    如何理解c和c++的复杂类型声明
    STM32 时钟系统
    STM32 系统架构
    运放参数的详细解释和分析-part1,输入偏置电流和输入失调电流【转】
    ROM、RAM、DRAM、SRAM、FLASH的区别?
    FATFS模块应用笔记
    关于I2C和SPI总线协议【转】
    USB编程概念
    Ubuntu手机识别
  • 原文地址:https://www.cnblogs.com/liaoguifa/p/2844446.html
Copyright © 2011-2022 走看看