zoukankan      html  css  js  c++  java
  • Uva 113 Power of Cryptography

    Power of Cryptography 

    Background

    Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers modulo functions of these primes. Work in this area has resulted in the practical use of results from number theory and other branches of mathematics once considered to be of only theoretical interest.

    This problem involves the efficient computation of integer roots of numbers.

    The Problem

    Given an integer tex2html_wrap_inline32 and an integer tex2html_wrap_inline34 you are to write a program that determines tex2html_wrap_inline36 , the positivetex2html_wrap_inline38 root of p. In this problem, given such integers n and pp will always be of the form tex2html_wrap_inline48 for an integerk (this integer is what your program must find).

    The Input

    The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs tex2html_wrap_inline56 , tex2html_wrap_inline58 and there exists an integer ktex2html_wrap_inline62 such that tex2html_wrap_inline64 .

    The Output

    For each integer pair n and p the value tex2html_wrap_inline36 should be printed, i.e., the number k such that tex2html_wrap_inline64 .

    Sample Input

    2
    16
    3
    27
    7
    4357186184021382204544

    Sample Output

    4
    3
    1234

    #include<stdio.h>
    #include<math.h>
    int main()
    {
        double x, y;
        int k;
        while(scanf("%lf%lf", &x, &y) != EOF)
        {
            k = (int)(pow(y, 1.0/x) + 0.5);
            printf("%d\n", k); 
        }
        return 0;
    }

    解题思路:

    说实话,大数的问题也让人做怕了,一开始拿到这题目看了之后真的是一点思路都没有啊,但后来…… (怎么就想起桃花源记的一句话呢:未果,寻病终)



  • 相关阅读:
    Office办公 如何设置WPS的默认背景大小
    百科知识 已知三角形三条边长,如何求解三角形的面积
    Office 如何添加Adobe Acrobat虚拟PDF打印机
    电脑技巧 如何保存网页为PDF
    JAVA Eclipse打开报错failed to load the jni shared library怎么办
    JAVA Eclipse如何导入已有的项目
    easy UI获取数据,打开毕弹窗
    easyUi 的DataGrid的绑定
    MVC异步分页
    MVC分页
  • 原文地址:https://www.cnblogs.com/liaoguifa/p/2924005.html
Copyright © 2011-2022 走看看