zoukankan      html  css  js  c++  java
  • Uva 10177 (2/3/4)D Sqr/Rects/Cubes/Boxes?

    Problem J

    (2/3/4)-D Sqr/Rects/Cubes/Boxes?

    Input: standard input

    Output: standard output

    Time Limit: 2 seconds

    You can see a (4x4) grid below. Can you tell me how many squares and rectangles are hidden there? You can assume that squares are not rectangles. Perhaps one can count it by hand but can you count it for a (100x100) grid or a (10000x10000) grid. Can you do it for higher dimensions? That is can you count how many cubes or boxes of different size are there in a (10x10x10) sized cube or how many hyper-cubes or hyper-boxes of different size are there in a four-dimensional (5x5x5x5) sized hypercube. Remember that your program needs to be very efficient. You can assume that squares are not rectangles, cubes are not boxes and hyper-cubes are not hyper-boxes.

    Fig: A 4x4 Grid

    Fig: A 4x4x4 Cube

     

    Input

    The input contains one integer N (0<=N<=100) in each line, which is the length of one side of the grid or cube or hypercube. As for the example above the value ofN is 4. There may be as many as 100 lines of input.

    Output

    For each line of input, output six integers S2, R2, S3, R3, S4, R4 in a single line whereS2 means no of squares of different size in( NxN) two-dimensional grid,R2 means no of rectangles of different size in(NxN) two-dimensional grid.S3, R3, S4, R4 means similar cases in higher dimensions as described before. 

    Sample Input:

    1 2 3

    Sample Output:

    1 0 1 0 1 0

    5 4 9 18 17 64

    14 22 36 180 98 1198

    #include<stdio.h>
    
    int main()
    {
        long long s2, r2, s3, r3, s4, r4, n;
        int i;
        while(scanf("%lld", &n) != EOF)
        {
            s2 = n*(n+1)*(2*n+1)/6;
            
            for(r2=0,i=n; i>=1; --i)
            r2 += i*i*(i-1);
            
            s3 = s2 + r2;
            r3 = ((n+1)*n/2-1)*s3;
            
            for(s4=0,i=n; i>=1; --i)
            s4 += i*i*i*i;
            
            for(r4=0,i=n; i>=1; --i)
            r4 += i*(s3+r3-i*i*i);
            
            printf("%lld %lld %lld %lld %lld %lld\n", s2, r2, s3, r3, s4, r4);
        }
        return 0;
    }

    解题思路:

    四维N*N*N*N的情况和三维的情况差不多:

    S4 = n^4 + (n-1)^4 + ... ... + 1^4

    R4 = n*(S3+R3-n^3) + (n-1)*(S3+R3-(n-1)^3) + ... ... + 1*(R3+S3-1^3);


    推了两个小时,可耻地AC了(1y)

  • 相关阅读:
    机器学习、图像识别方面 书籍推荐 via zhihu
    网络工具 NetCat
    CSharp读取配置文件的类(简单实现)
    about future
    Google's BBR拥塞控制算法模型解析
    对称加密与非对称加密
    windows平台下新网络库RIO ( Winsock high-speed networking Registered I/O)
    在mac os下编译android -相关文章
    [原创] linux 下上传 datapoint数据到yeelink 【golang版本】同时上传2个数据点
    在 树莓派上使用 c++ libsockets library
  • 原文地址:https://www.cnblogs.com/liaoguifa/p/2945042.html
Copyright © 2011-2022 走看看