zoukankan      html  css  js  c++  java
  • Uva 784 Maze Exploration

      Maze Exploration 

    A maze of rectangular rooms is represented on a two dimensional grid as illustrated in figure 1a. Each point of the grid is represented by a character. The points of room walls are marked by the same character which can be any printable character different than `*', `_' and space. In figure 1 this character is `X'. All the other points of the grid are marked by spaces.

                   XXXXXXXXXXXXXXXXXXXXX             XXXXXXXXXXXXXXXXXXXXX
                   X   X   X   X   X   X             X###X###X###X   X   X
                   X           X   X   X             X###########X   X   X
                   X   X   X   X   X   X             X###X###X###X   X   X
                   XXXXXX XXX XXXXXXXXXX             XXXXXX#XXX#XXXXXXXXXX
                   X   X   X   X   X   X             X   X###X###X###X###X
                   X   X     *         X             X   X###############X
                   X   X   X   X   X   X             X   X###X###X###X###X
                   XXXXXXXXXXXXXXXXXXXXX             XXXXXXXXXXXXXXXXXXXXX
    
    a) Initial maze                    b) Painted maze

    Figure 1. Mazes of rectangular rooms

    All rooms of the maze are equal sized with all walls 3 points wide and 1 point thick as illustrated in figure 2. In addition, a wall is shared on its full length by the separated rooms. The rooms can communicate through doors, which are positioned in the middle of walls. There are no outdoor doors.

                         door
                           |
                         XX XX
                         X . X   measured from within the room
                   door - ...--  walls are 3 points wide
                         X . X__
                         XXXXX  |
                           |___  walls are one point thick
    
    Figure 2. A room with 3 doors

    Your problem is to paint all rooms of a maze which can be visited starting from a given room, called the `start room' which is marked by a star (`*') positioned in the middle of the room. A room can be visited from another room if there is a door on the wall which separates the rooms. By convention, a room is painted if its entire surface, including the doors, is marked by the character `#' as shown in figure 1b.

    Input 

    The program input is a text file structured as follows:

    1.
    The first line contains a positive integer which shows the number of mazes to be painted.
    2.
    The rest of the file contains the mazes.

    The lines of the input file can be of different length. The text which represents a maze is terminated by a separation line full of underscores (`_'). There are at most 30 lines and at most 80 characters in a line for each maze

    The program reads the mazes from the input file, paints them and writes the painted mazes on the standard output.

    Output 

    The output text of a painted maze has the same format as that which has been read for that maze, including the separation lines. The example below illustrates a simple input which contains a single maze and the corresponding output.

    Sample Input 

    2
    XXXXXXXXX
    X   X   X
    X *     X
    X   X   X
    XXXXXXXXX
    X   X
    X   X
    X   X
    XXXXX
    _____
    XXXXX
    X   X
    X * X
    X   X
    XXXXX
    _____
    

    Sample Output 

    XXXXXXXXX
    X###X###X
    X#######X
    X###X###X
    XXXXXXXXX
    X   X
    X   X
    X   X
    XXXXX
    _____
    XXXXX
    X###X
    X###X
    X###X
    XXXXX
    _____
    

    Miguel Revilla 
    2001-01-05
     
    /*填充房间
     *Author:xueying
     *Time: 2013-3-28 21:30:24
     *Rank: 464/3636
     *Verdict: Accept(1y)
     *解题思路:输入处理,四个方向深度查找
     */ 
    
    #include<stdio.h>
    #include<string.h>
    #include<stdlib.h>
    
    void Traverse(char (*maze)[82], int cnt, int row, int column)
    {
        maze[row][column] = '#';
        int i, j, len;
        for(i=row, j=column-1; j>=0 && maze[i][j] == ' '; --j) Traverse(maze, cnt, i, j);
        for(i=row, j=column+1, len=strlen(maze[i]); j<len && maze[i][j] == ' '; ++j) Traverse(maze, cnt, i, j);
        for(i=row-1, j=column; i>=0 && maze[i][j] == ' '; --i) Traverse(maze, cnt, i, j);
        for(i=row+1, j=column; i<cnt && maze[i][j] == ' '; ++i) Traverse(maze, cnt, i, j);
        return;
    }
    int main()
    {
    
        char maze[32][82], end[82], *str;
        int n, i, j, row, column, flag, cnt, len;
        scanf("%d", &n);
        getchar();
        while(n--)
        {
            cnt = len = 0;
            str == NULL;
            while(fgets(maze[cnt], 82, stdin) != NULL)
            {
                len = strlen(maze[cnt]);
                if(maze[cnt][len-1] == '\n') maze[cnt][len-1] = '\0';
                else maze[cnt][len] = '\0';
                if((str = strchr(maze[cnt], '*')) != NULL)
                {
                    row = cnt;
                    column = str - maze[cnt];
                    maze[row][column] = '#';
                }
                if(maze[cnt][0] == '_') break;
                else cnt++;
            }
            Traverse(maze, cnt, row, column);
            for(i=0; i<=cnt; ++i)
            {
                printf("%s\n", maze[i]);
            }
            
        }
        return 0;
    }
  • 相关阅读:
    想让进程后台运行,试试Linux的nohup命令,3分钟学会。
    面试官:你能说一下Redis的常见应用场景吗?
    面试被问MySQL 主从复制,怎么破?
    Spring Boot 解决跨域问题的 3 种方案!
    Kafka如果丢了消息,怎么处理的?
    惊呆,这样操作 Nginx 并发数就能达到3w?
    easyexcel 自动设置列宽(转)
    Ubuntu18.04自适应VMware调整桌面大小
    IDEA将maven项目打包时同时带上项目的maven依赖(转)
    python 定时框架APScheduler
  • 原文地址:https://www.cnblogs.com/liaoguifa/p/2987648.html
Copyright © 2011-2022 走看看