zoukankan      html  css  js  c++  java
  • POJ1008(水)

    Maya Calendar
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 51462   Accepted: 15783

    Description

    During his last sabbatical, professor M. A. Ya made a surprising discovery about the old Maya calendar. From an old knotted message, professor discovered that the Maya civilization used a 365 day long year, called Haab, which had 19 months. Each of the first 18 months was 20 days long, and the names of the months were pop, no, zip, zotz, tzec, xul, yoxkin, mol, chen, yax, zac, ceh, mac, kankin, muan, pax, koyab, cumhu. Instead of having names, the days of the months were denoted by numbers starting from 0 to 19. The last month of Haab was called uayet and had 5 days denoted by numbers 0, 1, 2, 3, 4. The Maya believed that this month was unlucky, the court of justice was not in session, the trade stopped, people did not even sweep the floor.

    For religious purposes, the Maya used another calendar in which the year was called Tzolkin (holly year). The year was divided into thirteen periods, each 20 days long. Each day was denoted by a pair consisting of a number and the name of the day. They used 20 names: imix, ik, akbal, kan, chicchan, cimi, manik, lamat, muluk, ok, chuen, eb, ben, ix, mem, cib, caban, eznab, canac, ahau and 13 numbers; both in cycles.

    Notice that each day has an unambiguous description. For example, at the beginning of the year the days were described as follows:

    1 imix, 2 ik, 3 akbal, 4 kan, 5 chicchan, 6 cimi, 7 manik, 8 lamat, 9 muluk, 10 ok, 11 chuen, 12 eb, 13 ben, 1 ix, 2 mem, 3 cib, 4 caban, 5 eznab, 6 canac, 7 ahau, and again in the next period 8 imix, 9 ik, 10 akbal . . .

    Years (both Haab and Tzolkin) were denoted by numbers 0, 1, : : : , where the number 0 was the beginning of the world. Thus, the first day was:

    Haab: 0. pop 0

    Tzolkin: 1 imix 0
    Help professor M. A. Ya and write a program for him to convert the dates from the Haab calendar to the Tzolkin calendar.

    Input

    The date in Haab is given in the following format:
    NumberOfTheDay. Month Year

    The first line of the input file contains the number of the input dates in the file. The next n lines contain n dates in the Haab calendar format, each in separate line. The year is smaller then 5000.

    Output

    The date in Tzolkin should be in the following format:
    Number NameOfTheDay Year

    The first line of the output file contains the number of the output dates. In the next n lines, there are dates in the Tzolkin calendar format, in the order corresponding to the input dates.

    Sample Input

    3
    10. zac 0
    0. pop 0
    10. zac 1995

    Sample Output

    3
    3 chuen 0
    1 imix 0
    9 cimi 2801

    Source

     
     
    题目大意:玛雅人有两种纪念方法,Haab(一年365天,前18个月每月20天,最后一月5天)和Tzolkin(一年13月每月20天),给定Haab纪年法的每一天求对应的Tzolkin纪年法的表达形式。
     
    代码:
    View Code
    #include <stdio.h>
    #include <string.h>
    
    int Haab_Day = 0;
    char Haab_Month[100] = {0};
    int Haab_Year = 0;
    int sum = 0;
    
    char *Haab[19] = {"pop", "no", "zip", "zotz", "tzec",
             "xul", "yoxkin", "mol", "chen", "yax", "zac", 
             "ceh", "mac", "kankin", "muan", "pax", "koyab", 
             "cumhu", "uayet"};
    char *Tzolkin[21] = {"", "imix", "ik", "akbal", "kan", "chicchan", 
            "cimi", "manik", "lamat", "muluk", "ok", "chuen",
            "eb", "ben", "ix", "mem", "cib", "caban", "eznab", 
            "canac", "ahau"};
    
    int FindHaabMonth()
    {
        int i = 0;
        for ( i = 0; i < 19; ++i )
        {
            if ( !strcmp (Haab[i], Haab_Month) )
            {
                return i;
            }
        }
        return 0;
    }
    
    void FindTzolkinDay(int d)
    {
        printf ( "%d %s ", (d % 13) + 1, Tzolkin[(d % 20) + 1]);
    }
    
    void F_Haab()
    {
        sum = 365 * Haab_Year;
        int m = FindHaabMonth();
        sum += (m) * 20;
        sum += Haab_Day;
    }
    
    void F_Tzolkin()
    {
        int y = sum / 260;
        int d = sum % 260;
        FindTzolkinDay(d);
        printf ("%d\n", y);
    }
    
    int main()
    {
        int t = 0;
        scanf ( "%d", &t);
        printf ( "%d\n", t );
        while ( t-- )
        {
            sum = 0;
            scanf ( "%d. %s %d", &Haab_Day, &Haab_Month, &Haab_Year);
            F_Haab();
            F_Tzolkin();
        }
        return 0;
    }
  • 相关阅读:
    GO make&new区别
    GO 包相关
    GO 类型断言
    栈 队列 链表
    表达式求值
    动态规划 最长子序列
    04 单例模式
    02 简单工厂模式
    java设计模式 01 开山篇
    java基础07 多线程
  • 原文地址:https://www.cnblogs.com/libao/p/2465510.html
Copyright © 2011-2022 走看看