zoukankan      html  css  js  c++  java
  • HDU 1058 Humble Numbers(动态规划)

    Humble Numbers

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 7231    Accepted Submission(s): 3154

    Problem Description

    A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. 
    Write a program to find and print the nth element in this sequence

    Input

    The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.

    Output

    For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.

    Sample Input

    1

    2

    3

    4

    11

    12

    13

    21

    22

    23

    100

    1000

    5842

    0

    Sample Output

    The 1st humble number is 1.

    The 2nd humble number is 2.

    The 3rd humble number is 3.

    The 4th humble number is 4.

    The 11th humble number is 12.

    The 12th humble number is 14.

    The 13th humble number is 15.

    The 21st humble number is 28.

    The 22nd humble number is 30.

    The 23rd humble number is 32.

    The 100th humble number is 450.

    The 1000th humble number is 385875.

    The 5842nd humble number is 2000000000.

    Source

    University of Ulm Local Contest 1996

    Recommend

    JGShining

    解题报告:就是求一个数,要求是2,3,5,7的倍数,并且求出他们的顺序,状态方程:dp[i]=Min(dp[x2]*2,dp[x3]*3,dp[x5]*5,dp[x7]*7);找到比dp[i-1]相离最近的且比dp[i-1]大的值,并让xn加1,这样就求出来就有顺序了!再注意输出格式就OK了!

    代码如下:

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <cstdlib>
    using namespace std;
    const int N =5843;
    int dp[N];
    int Min(int a,int b,int c,int d)
    {
    int ans,e,f;
    e=a<b?a:b;
    f=c<d?c:d;
    ans=e<f?e:f;
    return ans;
    }
    void DP()
    {
    int i,x2,x3,x5,x7;
    dp[1]=1;
    x2=x3=x5=x7=1;
    for(i=2;i<=N-1;i++)
    {
    dp[i]=Min(dp[x2]*2,dp[x3]*3,dp[x5]*5,dp[x7]*7);//找到比dp[i-1]相离最近的且比dp[i-1]大的值
    if(dp[i]==dp[x2]*2)
    {
    x2++;
    }
    if(dp[i]==dp[x3]*3)
    {
    x3++;
    }
    if(dp[i]==dp[x5]*5)
    {
    x5++;
    }
    if(dp[i]==dp[x7]*7)
    {
    x7++;
    }
    }
    }
    int main()
    {
    int n;
    DP();
    while(scanf("%d",&n)!=EOF&&n)
    {
    if(n%10==1&&n%100!=11)
    {
    printf("The %dst humble number is %d.\n",n,dp[n]);
    }
    else if(n%10==2&&n%100!=12)
    {
    printf("The %dnd humble number is %d.\n",n,dp[n]);
    }
    else if(n%10==3&&n%100!=13)
    {
    printf("The %drd humble number is %d.\n",n,dp[n]);
    }
    else
    {
    printf("The %dth humble number is %d.\n",n,dp[n]);
    }
    }
    return 0;
    }



  • 相关阅读:
    2020.05.27
    static{}静态代码块与{}普通代码块之间的区别
    Spring 注解@Autowired注解
    java:List的深拷贝
    IDEA中MAVEN无法自动加载的问题
    java Comparator接口
    JAVA ArrayList<E>
    JAVA BigInteger
    JAVA输入输出
    JAVA String,StringBuilder的一些API
  • 原文地址:https://www.cnblogs.com/lidaojian/p/2270886.html
Copyright © 2011-2022 走看看