zoukankan      html  css  js  c++  java
  • HDU 1009 FatMouse' Trade(贪心)

    1009 FatMouse' Trade

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 19485    Accepted Submission(s): 6041

    Problem Description

    FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
    The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

    Input

    The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

    Output

    For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

    Sample Input

    5 3

    7 2

    4 3

    5 2

    20 3

    25 18

    24 15

    15 10

    -1 -1

    Sample Output

    13.333

    31.500

    Author

    CHEN, Yue

    Source

    ZJCPC2004

    Recommend

    JGShining

    Statistic | Submit | Discuss | Note

    解题报告:先按J[i]/F[i]从大到小排序,再贪心就可以了!

    代码如下:

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <cstdlib>
    using namespace std;
    const int N =1010;
    struct node
    {
    double f;
    double j;
    double r;
    }a[N];
    int cmp(const void *a,const void *b)
    {
    return (*(struct node *)a).r > (*(struct node *)b).r?1:-1;
    }
    int main()
    {
    int m,n,i;
    double ans;
    while(scanf("%d%d",&m,&n)!=EOF)
    {
    memset(a,0,sizeof(a));
    if(m==-1&&n==-1)
    {
    break;
    }
    ans=0;
    for(i=0;i<n;i++)
    {
    scanf("%lf%lf",&a[i].f,&a[i].j);
    a[i].r=a[i].j/a[i].f;
    }
    qsort(a,n,sizeof(a[0]),cmp);
    for(i=0;i<n;i++)
    {
    if(m>=a[i].j)
    {
    ans+=a[i].f;
    m-=a[i].j;
    }
    else
    {
    ans+=(a[i].f/a[i].j)*m;
    break;
    }
    }
    printf("%.3lf\n",ans);
    }
    return 0;
    }
  • 相关阅读:
    POJ 2955 Brackets 区间DP
    POJ 3311 Hie with the Pie 最短路+状压DP
    POJ 3615 Cow Hurdles(最短路径flyod)
    hdu 3790 最短路径dijkstra(多重权值)
    poj 3254 Corn Fields 状压DP
    状压DP
    poj2411 Mondriaan's Dream 状压DP
    M: Mysterious Conch 字符串哈希
    哈希(hash)理解
    域渗透:GPP(Group Policy Preferences)漏洞
  • 原文地址:https://www.cnblogs.com/lidaojian/p/2278628.html
Copyright © 2011-2022 走看看