zoukankan      html  css  js  c++  java
  • ZOJ 1372 ZOJNetworking 最小生成树(Prim算法)

    Networking


    Time Limit: 2 Seconds      Memory Limit: 65536 KB


    You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible routes for the cables that may connect pairs of points. For each possible route between two points, you are given the length of the cable that is needed to connect the points over that route. Note that there may exist many possible routes between two given points. It is assumed that the given possible routes connect (directly or indirectly) each two points in the area.

    Your task is to design the network for the area, so that there is a connection (direct or indirect) between every two points (i.e., all the points are interconnected, but not necessarily by a direct cable), and that the total length of the used cable is minimal.
    Input

    The input file consists of a number of data sets. Each data set defines one required network. The first line of the set contains two integers: the first defines the number P of the given points, and the second the number R of given routes between the points. The following R lines define the given routes between the points, each giving three integer numbers: the first two numbers identify the points, and the third gives the length of the route. The numbers are separated with white spaces. A data set giving only one number P=0 denotes the end of the input. The data sets are separated with an empty line.
    The maximal number of points is 50. The maximal length of a given route is 100. The number of possible routes is unlimited. The nodes are identified with integers between 1 and P (inclusive). The routes between two points i and j may be given as i j or as j i.
    Output

    For each data set, print one number on a separate line that gives the total length of the cable used for the entire designed network.


    Sample Input

    1 0

    2 3
    1 2 37
    2 1 17
    1 2 68

    3 7
    1 2 19
    2 3 11
    3 1 7
    1 3 5
    2 3 89
    3 1 91
    1 2 32

    5 7
    1 2 5
    2 3 7
    2 4 8
    4 5 11
    3 5 10
    1 5 6
    4 2 12

    0
    Sample Output

    0
    17
    16
    26


    Source: Southeast Europe 2002

    Submit    Status

    解题报告:就是求最小生成树,因为从一个点到达另一个点有可能存在多条路径,从中选出最短的,再利用Prim算法即可!但是由于考试原因三个星期几乎没有编过程序了!花了一个小时才搞定!哎!编码能力下降了!坚持每天做题!

    代码如下:

    #include <iostream>
    #include <cstdio>
    #include <cstdlib>
    #include <cstring>
    using namespace std;
    const int N = 110;
    const int INF =99999999;
    int map[N][N],dis[N],visit[N];
    int n,m,ans;
    int Min(int x,int y)
    {
    return x<y?x:y;
    }
    int Prim()
    {
    int i,result,min,p,k;
    memset(dis,0,sizeof(dis));
    for(i=1;i<=n;i++)
    {
    dis[i]=map[1][i];
    }
    visit[1]=1;
    result=0;
    for(k=1;k<n;k++)
    {
    p=1;
    min=INF;
    for(i=1;i<=n;i++)
    {
    if(!visit[i]&&min>dis[i])
    {
    min=dis[i];
    p=i;
    }
    }
    visit[p]=1;
    result+=min;
    for(i=1;i<=n;i++)
    {
    if(!visit[i]&&dis[i]>map[p][i])
    {
    dis[i]=map[p][i];
    }
    }
    }
    return result;
    }
    int main()
    {
    int i,p,q,v,j;
    while(scanf("%d",&n)!=EOF&&n)
    {
    scanf("%d",&m);
    memset(map,0,sizeof(map));
    for(i=0;i<m;i++)
    {
    scanf("%d%d%d",&p,&q,&v);
    if(map[p][q])//如果此时有值的话,选出最小的值;
    {
    map[p][q]=map[q][p]=Min(v,map[p][q]);
    }
    else//当前没有值是直接赋值即可
    {
    map[p][q]=map[q][p]=v;
    }
    }
    for(i=1;i<=n;i++)//对没有连接的点初始化
    {
    for(j=1;j<=n;j++)
    {
    if(!map[i][j])
    {
    map[i][j]=map[j][i]=INF;
    }
    }
    }
    memset(visit,0,sizeof(visit));
    ans=0;
    if(m)
    {
    ans=Prim();
    }
    printf("%d\n",ans);
    }
    return 0;
    }



  • 相关阅读:
    Aras学习笔记 (8) Aras一个Web站点下创建多个Instances
    WebAPI学习笔记(3)Asp.net调用WebAPI Post方法传递参数
    简单工厂模式
    工厂模式
    文件信息
    C#压缩解压zip 文件
    Creo 2.0 Toolkit 解锁的问题
    Dojo Grid结合Ajax用法
    Aras Innovator时间验证
    Aras Innovator获取项目任务序列号
  • 原文地址:https://www.cnblogs.com/lidaojian/p/2310272.html
Copyright © 2011-2022 走看看