zoukankan      html  css  js  c++  java
  • HDU 1062 Text Reverse(简单模拟)

    Text Reverse

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 7548    Accepted Submission(s): 2869

    Problem Description

    Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them. 

    Input

    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
    Each test case contains a single line with several words. There will be at most 1000 characters in a line.

    Output

    For each test case, you should output the text which is processed.

    Sample Input

    3

    olleh !dlrow

    m'I morf .udh

    I ekil .mca 

    Sample Output

    hello world!

    I'm from hdu.

    I like acm.

    Hint

    Remember to use getchar() to read '\n' after the interger T, then you may use gets() to read a line and process it.

    Author

    Ignatius.L

    解题报告:

    简单的处理字符串问题,如果遇见字符串问题要合理利用getchar(),在注意处理边界问题

    代码如下:
    #include <iostream>
    #include <cstring>
    using namespace std;
    char str[1001];
    int main()
    {
    int i, len, n, j;
    scanf("%d", &n);
    getchar();//度掉回车
    while (n --)
    {
    gets(str);//gets()函数是以回车作为结束标志
    len = strlen(str);
    for (i = 0; i < len; ++i)
    {
    if (str[i]== ' ')
    {
    j = i - 1;
    while (str[j] != ' '&&j >=0)
    {
    printf("%c", str[j]);
    j --;
    }
    printf(" ");
    }
    else if (i == len - 1)//对最后一个单词的处理
    {
    j = i;
    while (str[j] != ' '&&j >=0)
    {
    printf("%c", str[j]);
    j --;
    }
    }
    }
    printf("\n");
    }
    return 0;
    }

     

  • 相关阅读:
    反向传播(BP)算法理解以及Python实现
    tf.pad()
    Machine Learning-KNN
    【Python之os模块】使用
    Python实现返回指定范围内的所有素数
    Python中的map_reduce
    杨辉三角的Python实现
    斐波那契数列的Python实现
    Python中的可迭代对象
    NoReferencedTableError: Foreign key associated with column ** with which to generate a foreign key to target column 'id'
  • 原文地址:https://www.cnblogs.com/lidaojian/p/2345511.html
Copyright © 2011-2022 走看看