zoukankan      html  css  js  c++  java
  • POJ 2586 Y2K Accounting Bug(简单贪心)

    Y2K Accounting Bug
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 6101   Accepted: 2982

    Description

    Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc. 
    All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite. 

    Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.

    Input

    Input is a sequence of lines, each containing two positive integers s and d.

    Output

    For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.

    Sample Input

    59 237
    375 743
    200000 849694
    2500000 8000000
    

    Sample Output

    116
    28
    300612
    Deficit
    

    Source

    解题报告:这道题的题意就是一个公司每五个月统计一次盈利状况,例如一年中1--5月,2--6月,统计一次,题目给出5个月中一个月的盈利,和一个月的亏损状况,当我们求出最大的盈利状况,并输出,若亏损这输出Deficit。就是让五个月中尽量盈利月份占得多即可,
    代码如下:
    #include <iostream>
    #include <cstdio>
    using namespace std;
    int main()
    {
    int s, d, ans;
    while (scanf("%d%d", &s, &d) != EOF)
    {
    ans = 0;
    if (4 * s < d)
    {
    ans = 10 * s - 2 * d;
    }
    else if (3 * s < 2 *d)
    {
    ans = 8 * s - 4 * d;
    }
    else if (2 * s < 3 * d)
    {
    ans = 6 * s - 6 * d;
    }
    else if (s < 4 * d)
    {
    ans = 3 * s - 9 * d;
    }
    if (ans <= 0)
    {
    printf ("Deficit\n");
    }
    else
    {
    printf("%d\n", ans);
    }
    }
    return 0;
    }
  • 相关阅读:
    ServU和win2003防火墙的设置
    面试题02.05 链表求和
    【每日一题】LeetCode1. 两数之和
    【每日一题】Leetcode50. Pow(x,n)
    ASP连接查询access和sqlserver的代码
    各种播放器(视频点播)代码大全 
    电脑操作最忌讳的小动作
    网络小知识
    C#、Java比较
    10年互联网十大失败案例
  • 原文地址:https://www.cnblogs.com/lidaojian/p/2365462.html
Copyright © 2011-2022 走看看