zoukankan      html  css  js  c++  java
  • POJ 2524 Ubiquitous Religions(并查集)

    Ubiquitous Religions
    Time Limit: 5000MS   Memory Limit: 65536K
    Total Submissions: 16083   Accepted: 7764

    Description

    There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in. 

    You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

    Input

    The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

    Output

    For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

    Sample Input

    10 9
    1 2
    1 3
    1 4
    1 5
    1 6
    1 7
    1 8
    1 9
    1 10
    10 4
    2 3
    4 5
    4 8
    5 8
    0 0
    

    Sample Output

    Case 1: 1
    Case 2: 7
    

    Hint

    Huge input, scanf is recommended.

    Source

     

    解题报告:题意就是每个人是不同地区的,给出人数,和他们之间的关系,统计这些人所在不同区域的个数,其实就是统计一下集合的个数,利用并查集的算法就能实现这一功能;

    代码如下:

    #include <iostream>
    #include <cstdio>
    using namespace std;
    const int N = 50010;
    int father[N], ans;
    void Makeset() //初始化函数
    {
    int i;
    for (i = 0; i < N; ++i)
    {
    father[i] = i;
    }
    }
    int Find(int x) //找集合的“根”
    {
    if (father[x] != x)
    {
    father[x] = Find(father[x]);
    }
    return father[x];
    }
    void Merge(int x, int y) //若不在一个集合中则合并到一个集合,若在一个集合中则不处理
    {
    int i, j;
    i = Find(x);
    j = Find(y);
    if (i != j)//不在一个集合中的处理
    {
    ans --; //集合的数目减1
    if (i > j)
    {
    father[i] = j;
    }
    else
    {
    father[j] = i;
    }
    }
    }
    int main()
    {
    int n, m, i, p, q, count;
    count = 0;
    while (scanf("%d%d", &n, &m) != EOF && n && m)
    {
    count ++;
    ans = n;//假设集合的个数最多
    Makeset();
    for (i = 0; i < m; ++i)
    {
    scanf("%d%d", &p, &q);
    Merge(p, q);
    }
    printf("Case %d: %d\n", count, ans);//ans统计的是集合的个数
    }
    return 0;
    }



  • 相关阅读:
    时尚生活小秘方[转载]
    武侠片上的99个公式镜头
    SQL语句优化技术分析
    LoadRunner监视的性能计数器
    圣诞收到最搞笑的短信两则
    loadrunner 运行状态描述
    ORACLE 常用脚本[转载]
    关于内存泄漏检测问题,和大家一起分享
    小笑话
    [转贴] ++ 一个北大女孩给男友的道歉信(爆笑!!!)相当经典
  • 原文地址:https://www.cnblogs.com/lidaojian/p/2365523.html
Copyright © 2011-2022 走看看