zoukankan      html  css  js  c++  java
  • POJ 1840 Eqs (Hash)

    Eqs

    Time Limit: 5000MS

     

    Memory Limit: 65536K

    Total Submissions: 7827

     

    Accepted: 3811

    Description

    Consider equations having the following form: 
    a1x13+ a2x23+ a3x33+ a4x43+ a5x53=0 
    The coefficients are given integers from the interval [-50,50]. 
    It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}. 

    Determine how many solutions satisfy the given equation. 

    Input

    The only line of input contains the 5 coefficients a1, a2, a3, a4, a5, separated by blanks.

    Output

    The output will contain on the first line the number of the solutions for the given equation.

    Sample Input

    37 29 41 43 47

    Sample Output

    654

    Source

    Romania OI 2002

     解题报告:这道题的题意就是已知5元3次a1x13+ a2x23+ a3x33+ a4x43+ a5x53=0的解为(x1, x2, x3, x4, x5),各个x满足 -50 <= x <= 50,且x为非0整数。现给定各参数a的值,问这个5元方程有多少组解满足上述条件。思路:利用Hash,因为要枚举5个x,复杂度就是100^5,即10^10,,一般的方法肯定超时!先枚举前两个x,再枚举后三个x,最后在比对即可;

    代码如下:

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <cmath>
    using namespace std;
    const int MAX = 100007;
    int hash[MAX][25], num[MAX];
    int a[5];
    int main()
    {
    int i, j, k, ans, temp, mark, p;
    for (i = 0; i < 5; ++i)
    {
    scanf("%d", &a[i]);
    }
    ans = 0;
    for (i = -50; i <= 50; ++i)//枚举前两个x;
    {
    for (j = -50; j <= 50; ++j)
    {
    if (i && j)
    {
    temp = a[0] * i * i * i + a[1] * j * j * j;
    mark = abs(temp) % MAX;//建立hash表
    hash[mark][num[mark]] = temp;
    num[mark] ++;//处理冲突
    }
    }
    }
    for (i = -50; i <= 50; ++i)//枚举后三个x;
    {
    for (j = -50; j <= 50; ++j)
    {
    for (k = -50; k <= 50; ++k)
    {
    if (i && j && k)
    {
    temp = a[2] * i * i *i + a[3] * j * j * j + a[4] * k * k * k;
    mark = abs(temp) % MAX;
    for (p = 0; p < num[mark]; ++p)
    {
    if (hash[mark][p] == temp)//若能成功
    {
    ans ++;
    }
    }
    }
    }
    }
    }
    printf("%d\n", ans);
    return 0;
    }



  • 相关阅读:
    《原则》读书笔记
    mvn + testng + allure 生成自动化测试报告
    poj3264RMQ
    poj3928pingpong区间和
    uva11361数位dp
    Poj2795Exploring PyramidsDp
    uva11137Dp
    uva11375Dp
    三道组合题
    poj1379模拟退火
  • 原文地址:https://www.cnblogs.com/lidaojian/p/2416781.html
Copyright © 2011-2022 走看看