zoukankan      html  css  js  c++  java
  • HDU 1063 Exponentiation(R的N次方)(Java版)

    Exponentiation

    Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 3847    Accepted Submission(s): 1015

    Problem Description

    Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. 
    This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25. 

    Input

    The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

    Output

    The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.

    Sample Input

    95.123 12

    0.4321 20

    5.1234 15

    6.7592  9

    98.999 10

    1.0100 12

    Sample Output

    548815620517731830194541.899025343415715973535967221869852721

    .00000005148554641076956121994511276767154838481760200726351203835429763013462401

    43992025569.928573701266488041146654993318703707511666295476720493953024

    29448126.764121021618164430206909037173276672

    90429072743629540498.107596019456651774561044010001

    1.126825030131969720661201

    Source

    East Central North America 1988

    Recommend

    PrincetonBoy

    解题报告:这道题就是让求R的n次方,如果结果小于1,输出的时候去掉小数的前面的0,用Java写比较简单,

    代码如下:

    import java.util.Scanner;
    import java.math.BigDecimal;
    public class Main{
        public static void main(String[] args){
            Scanner scan = new Scanner(System.in);
            BigDecimal R, power;
            int n;
            String ans;
            while (scan.hasNextBigDecimal()){
                R = scan.nextBigDecimal();
                n = scan.nextInt();
                power = R.pow(n);//R的n次方
                power = power.stripTrailingZeros();//去掉后导零
                ans = power.toPlainString();//将数字转化为字符串
                if (ans.indexOf("0") == 0){
                    ans = ans.substring(1);//如果结果小于1就去掉小数点前面的0;
                }
                System.out.println(ans);
            }
        }
    }
  • 相关阅读:
    POJ 1320 Street Numbers(佩尔方程)
    hdu 3292 No more tricks, Mr Nanguo
    佩尔方程
    hdu 4825 xor sum(字典树+位运算)
    Xor Sum 2(位运算)
    数串
    EJS
    JQuery性能优化
    常用正则
    JavaScript prototype继承中的问题
  • 原文地址:https://www.cnblogs.com/lidaojian/p/2514109.html
Copyright © 2011-2022 走看看