zoukankan      html  css  js  c++  java
  • POJ 2039:To and Fro

    To and Fro
    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 8632   Accepted: 5797

    Description

    Mo and Larry have devised a way of encrypting messages. They first decide secretly on the number of columns and write the message (letters only) down the columns, padding with extra random letters so as to make a rectangular array of letters. For example, if the message is "There’s no place like home on a snowy night" and there are five columns, Mo would write down 
    t o i o y
    
    h p k n n
    
    e l e a i
    
    r a h s g
    
    e c o n h
    
    s e m o t
    
    n l e w x

    Note that Mo includes only letters and writes them all in lower case. In this example, Mo used the character "x" to pad the message out to make a rectangle, although he could have used any letter. 

    Mo then sends the message to Larry by writing the letters in each row, alternating left-to-right and right-to-left. So, the above would be encrypted as 

    toioynnkpheleaigshareconhtomesnlewx 

    Your job is to recover for Larry the original message (along with any extra padding letters) from the encrypted one. 

    Input

    There will be multiple input sets. Input for each set will consist of two lines. The first line will contain an integer in the range 2. . . 20 indicating the number of columns used. The next line is a string of up to 200 lower case letters. The last input set is followed by a line containing a single 0, indicating end of input.

    Output

    Each input set should generate one line of output, giving the original plaintext message, with no spaces.

    Sample Input

    5
    toioynnkpheleaigshareconhtomesnlewx
    3
    ttyohhieneesiaabss
    0

    Sample Output

    theresnoplacelikehomeonasnowynightx
    thisistheeasyoneab

    洪水,加密解密。用二维数组存储,以行为单位输入,再从列为单位输出。

    代码:

    #include <iostream>
    #include <algorithm>
    #include <cmath>
    #include <vector>
    #include <string>
    #include <cstring>
    #pragma warning(disable:4996)
    using namespace std;
    
    int column;
    char value[201][201];
    string test;
    
    int main()
    {
    	int i,j,num;
    	int len,row;
    	while(cin>>column)
    	{
    		if(column==0)
    			break;
    		cin>>test;
    
    		len=test.length();
    		row=len/column;
    		num=0;
    
    		for(i=1;i<=row;i++)
    		{
    			if(i%2)
    			{
    				for(j=1;j<=column;j++)
    				{
    					value[i][j]=test[num];
    					num++;
    				}
    			}
    			else
    			{
    				for(j=column;j>=1;j--)
    				{
    					value[i][j]=test[num];
    					num++;
    				}
    			}
    		}
    		for(j=1;j<=column;j++)
    		{
    			for(i=1;i<=row;i++)
    			{
    				cout<<value[i][j];
    			}
    		}
    		cout<<endl;
    	}
    	return 0;
    }
    


    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    Loadrunner 参数化&参数化策略&参数化mysql
    Loadrunner 录制脚本注意事项
    Centos7卸载nginx及php、php-fpm方法
    卸载apache
    apache配置
    centOs
    ajax-php跨域请求
    安装php
    apache
    java集合类,HashMap,ArrayList
  • 原文地址:https://www.cnblogs.com/lightspeedsmallson/p/4785765.html
Copyright © 2011-2022 走看看