zoukankan      html  css  js  c++  java
  • POJ 1942:Paths on a Grid

    Paths on a Grid
    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 22918   Accepted: 5651

    Description

    Imagine you are attending your math lesson at school. Once again, you are bored because your teacher tells things that you already mastered years ago (this time he's explaining that (a+b)2=a2+2ab+b2). So you decide to waste your time with drawing modern art instead. 

    Fortunately you have a piece of squared paper and you choose a rectangle of size n*m on the paper. Let's call this rectangle together with the lines it contains a grid. Starting at the lower left corner of the grid, you move your pencil to the upper right corner, taking care that it stays on the lines and moves only to the right or up. The result is shown on the left: 

    Really a masterpiece, isn't it? Repeating the procedure one more time, you arrive with the picture shown on the right. Now you wonder: how many different works of art can you produce?

    Input

    The input contains several testcases. Each is specified by two unsigned 32-bit integers n and m, denoting the size of the rectangle. As you can observe, the number of lines of the corresponding grid is one more in each dimension. Input is terminated by n=m=0.

    Output

    For each test case output on a line the number of different art works that can be generated using the procedure described above. That is, how many paths are there on a grid where each step of the path consists of moving one unit to the right or one unit up? You may safely assume that this number fits into a 32-bit unsigned integer.

    Sample Input

    5 4
    1 1
    0 0
    

    Sample Output

    126
    2

    给了一个n*m的格子,要从左下走到右上,问有多少种走法。

    一共一定是走n+m步,这其中又必然有n步向上,m步向右。所以结果就是C[n+m][n]或者C[n+m][m]

    代码:

    #include <iostream>
    #include <algorithm>
    #include <cmath>
    #include <vector>
    #include <string>
    #include <cstring>
    #pragma warning(disable:4996)
    using namespace std;
    
    unsigned long long weight,height;
    
    int main()
    {
    	unsigned long long small,lo;
    	unsigned long long i,j,result;
    	while(cin>>weight>>height)
    	{
    		if(weight+height==0)//被0 5这样的坑死 这样的输出1 之前我自己还先判断一下 然后输出0...
    			break;
    		small=min(weight,height);
    		lo=weight+height;
    		
    		result=1;
    
    		for(i=lo,j=1;j<=small;i--,j++)
    		{
    			result = (result*i)/j;
    		}
    
    		cout<<result<<endl;
    	}
    	return 0;
    }
    



    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    矩阵十题(7)
    线段树成段更新 poj 3468 A Simple Problem with Integers
    线段树单点更新 hdu 2795 Billboard
    线段树成段更新 poj 2528 Mayor's posters
    矩阵十题(10)
    矩阵十题(8)
    矩阵十题(5)
    矩阵十题(6)
    矩阵十题(9)
    矩阵十题(4)
  • 原文地址:https://www.cnblogs.com/lightspeedsmallson/p/4785767.html
Copyright © 2011-2022 走看看