zoukankan      html  css  js  c++  java
  • POJ 1887:Testing the CATCHER 求递减序列的最大值

    Testing the CATCHER
    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 16131   Accepted: 5924

    Description

    A military contractor for the Department of Defense has just completed a series of preliminary tests for a new defensive missile called the CATCHER which is capable of intercepting multiple incoming offensive missiles. The CATCHER is supposed to be a remarkable defensive missile. It can move forward, laterally, and downward at very fast speeds, and it can intercept an offensive missile without being damaged. But it does have one major flaw. Although it can be fired to reach any initial elevation, it has no power to move higher than the last missile that it has intercepted. 

    The tests which the contractor completed were computer simulations of battlefield and hostile attack conditions. Since they were only preliminary, the simulations tested only the CATCHER's vertical movement capability. In each simulation, the CATCHER was fired at a sequence of offensive missiles which were incoming at fixed time intervals. The only information available to the CATCHER for each incoming missile was its height at the point it could be intercepted and where it appeared in the sequence of missiles. Each incoming missile for a test run is represented in the sequence only once. 

    The result of each test is reported as the sequence of incoming missiles and the total number of those missiles that are intercepted by the CATCHER in that test. 

    The General Accounting Office wants to be sure that the simulation test results submitted by the military contractor are attainable, given the constraints of the CATCHER. You must write a program that takes input data representing the pattern of incoming missiles for several different tests and outputs the maximum numbers of missiles that the CATCHER can intercept for those tests. For any incoming missile in a test, the CATCHER is able to intercept it if and only if it satisfies one of these two conditions: 

    The incoming missile is the first missile to be intercepted in this test. 
    -or- 
    The missile was fired after the last missile that was intercepted and it is not higher than the last missile which was intercepted.

    Input

    The input data for any test consists of a sequence of one or more non-negative integers, all of which are less than or equal to 32,767, representing the heights of the incoming missiles (the test pattern). The last number in each sequence is -1, which signifies the end of data for that particular test and is not considered to represent a missile height. The end of data for the entire input is the number -1 as the first value in a test; it is not considered to be a separate test.

    Output

    Output for each test consists of a test number (Test #1, Test #2, etc.) and the maximum number of incoming missiles that the CATCHER could possibly intercept for the test. That maximum number appears after an identifying message. There must be at least one blank line between output for successive data sets. 

    Note: The number of missiles for any given test is not limited. If your solution is based on an inefficient algorithm, it may not execute in the allotted time. 

    Sample Input

    389
    207
    155
    300
    299
    170
    158
    65
    -1
    23
    34
    21
    -1
    -1

    Sample Output

    Test #1:
      maximum possible interceptions: 6
    
    Test #2:
      maximum possible interceptions: 2

    求递减序列的最大值,和递增没什么区别。DP。

    代码:

    #include <iostream>
    #include <algorithm>
    #include <cmath>
    #include <vector>
    #include <string>
    #include <cstring>
    #pragma warning(disable:4996)
    using namespace std;
    
    int num[10005];
    int dp[10005];
    
    int main()
    {
    	//freopen("i.txt","r",stdin);
    	//freopen("o.txt","w",stdout);
    
    	int Test=1,i,j,sum,max_v;
    	while(cin>>num[1])
    	{
    		if(num[1]==-1)
    			break;
    		cout<<"Test #"<<Test<<":"<<endl;
    		cout<<"  maximum possible interceptions: ";
    		Test++;
    		dp[1]=1;
    		i=2;
    
    		while(cin>>num[i])
    		{
    			if(num[i]==-1)
    				break;
    			dp[i]=1;
    			i++;
    		}
    		sum=i;
    		for(i=1;i<=sum;i++)
    		{
    			max_v=0;
    			for(j=1;j<i;j++)
    			{
    				if(num[i]<=num[j])
    				{
    					max_v=max(max_v,dp[j]);
    				}
    			}
    			dp[i]=max_v+1;
    		}
    		cout<<dp[sum]-1;
    		cout<<endl<<endl;
    	}
    	return 0;
    }
    




    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    重装系统后texstudio拼写检查不工作
    git bash使用端口转发连接服务器
    YCSB-mapkeeper
    编译thrift外篇-关于默认链接包-(使用mapkeeper运行leveldb成功)
    编译Thrift
    Could not resolve view with name 'sys/login' in servlet with name 'dispatcher'
    Eclipse创建一个Maven Web项目
    Maven安装配置
    使用Maven创建Web应用程序项目
    org.apache.jasper.JasperException: Unable to compile class for JSP:
  • 原文地址:https://www.cnblogs.com/lightspeedsmallson/p/4785768.html
Copyright © 2011-2022 走看看