zoukankan      html  css  js  c++  java
  • POJ 1469:COURSES

    COURSES
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 19458   Accepted: 7658

    Description

    Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions: 

    • every student in the committee represents a different course (a student can represent a course if he/she visits that course) 
    • each course has a representative in the committee 

    Input

    Your program should read sets of data from the std input. The first line of the input contains the number of the data sets. Each data set is presented in the following format: 

    P N 
    Count1 Student1 1 Student1 2 ... Student1 Count1 
    Count2 Student2 1 Student2 2 ... Student2 Count2 
    ... 
    CountP StudentP 1 StudentP 2 ... StudentP CountP 

    The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses �from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N. 
    There are no blank lines between consecutive sets of data. Input data are correct. 

    Output

    The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

    Sample Input

    2
    3 3
    3 1 2 3
    2 1 2
    1 1
    3 3
    2 1 3
    2 1 3
    1 1

    Sample Output

    YES
    NO

    选课。给了每一门课有那些学生选。要问的是在给定的关系的情况下,能不能求出一个学生集合,这个集合里面能够满足这样的关系:

    1.每门课都能派出一个学生代表。

    2.每个学生都代表了一门课。

    不能更匈牙利了。

    代码:

    #include <iostream>
    #include <algorithm>
    #include <cmath>
    #include <vector>
    #include <string>
    #include <cstring>
    #pragma warning(disable:4996)
    using namespace std;
    
    int grid[305][305];
    int link[305];
    int visit[305];
    int n,k,V1,V2;
    int result;
    
    bool dfs(int x)
    {
    	int i;
    	for(i=1;i<=V2;i++)
    	{
    		if(grid[x][i]==1&&visit[i]==0)
    		{
    			visit[i]=1;
    			if(link[i]==-1||dfs(link[i]))
    			{
    				link[i]=x;
    				return true;
    			}
    		}
    	}
    	return false;
    }
    
    bool Magyarors()
    {
    	int i;
    	
    	result=0;
    	memset(link,-1,sizeof(link));//!!这里不能是0
    
    	for(i=1;i<=V1;i++)
    	{
    		memset(visit,0,sizeof(visit));
    		if(!dfs(i))
    		{
    			return false;
    		}
    	}
    	return true;
    }
    
    int main()
    {
    	int Test,i,j,num,temp;
    	cin>>Test;
    	
    	while(Test--)
    	{
    		memset(grid,0,sizeof(grid));
    		cin>>V1>>V2;
    		
    		for(i=1;i<=V1;i++)
    		{
    			scanf("%d",&num);
    			for(j=1;j<=num;j++)
    			{
    				scanf("%d",&temp);
    				grid[i][temp]=1;
    			}
    		}
    		if(V1>V2)
    		{
    			cout<<"NO"<<endl;
    		}
    		else
    		{
    			if(Magyarors())
    			{
    				cout<<"YES"<<endl;
    			}
    			else
    			{
    				cout<<"NO"<<endl;
    			}
    		}
    	}
    	return 0;
    }
    


    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    常用的npm指令总结
    Mongoose基础
    2016总结与展望
    sleep与wait的区别
    查询平均分大于80分的学生
    求最大不重复子串
    快速排序
    按位与(&)运算的作用
    异或运算的作用
    java 字符串中的每个单词的倒序输出
  • 原文地址:https://www.cnblogs.com/lightspeedsmallson/p/4785770.html
Copyright © 2011-2022 走看看