zoukankan      html  css  js  c++  java
  • POJ 2128:Highways

    Highways
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 2730   Accepted: 1008   Special Judge

    Description

    In a distant country Lineland there are N cities and they are all located along the highway. The highway is a straight line; it starts from the first city and runs through the second, third city and so on, ending in the N-th city. The i-th city is located at the distance of X i miles from the first one. 
    The highway is wide and smooth, so it is a pleasure for all people to drive along it. But there is one problem --- all roads in Lineland, including the highway, are one-way. So people are only allowed to drive along the highway from the city with smaller number to the city with greater number and they have to use country roads to get back, and that is not such a great pleasure indeed. 
    After the new president Mr. Pathwayson was elected in Lineland, he has decided that he would like to make it easier for people to get from one town to another. But he does not dare to change the traditions, and make the highway two-way. Therefore he has decided to build new highways to connect the cities, so that it would be possible to get from any city to any other one by highways. Traditionally, the new highways must be one-way. 
    Of course, Mr. Pathwayson is a great president, and he wants people to remember him in years. After a thought he has decided that building just one highway would not be enough for that. Therefore he has decided that he must build two new highways. Each highway would connect two different cities. Since people are anxious about their health, and cars running along the highway produce dangerous wastes, each new highway must not pass through any cities, except the cities it connects. Also building two new highways in one city would disturb people too much, so all the cities that would be the ends of the new highways must be different. 
    You are the assistant of the minister of transportation of Lineland, so you are asked to choose the cities to be connected by the new highways. Since the cost of building a highway is proportional to its length, the total length of the highways must be minimal possible. Write a program to solve this problem. You may assume that the distance between two cities along the new highway is equal to the distance between those cities along the main highway.

    Input

    The first line of the input contains N (2 <= N <= 50 000). 
    Next line contains N - 1 integer numbers: X2 , X3 , . . . , XN (1 <= X2 < X3 < . . . < XN <= 109 ).

    Output

    If it is impossible to build the highways satisfying all requirements, print number 0 on the first line of the output. 
    In the other case on the first line of the output file print the minimal possible total length of the highways to be built. On the second line print S1 , E1 , S2 and E2 --- the numbers of the cities to connect by the first and the second highway, respectively. Note that highways are one-way and must run from S1 to E1 and from S2 to E2 .

    Sample Input

    4
    3 5 10

    Sample Output

    12
    3 1 4 2

    题意是有N个城市在一条高速公路上,这条高速公路是一条直线。但是这条高速公路是单向的,人们去的时候可以走高速公路,回来的时候又只能走country road了。

    所以新上任的市长打算在回去的方向上建立两条路(其实一条整个回去的路就足够了,但是市长任性,就两条),满足路上的城市都能来回都走上高速公路,问修这两条路的最短距离是多少。

    要在回去的方向上修两条能够在所有城市都能互相来回,说明这两条路必然重复了一段距离,那既然必然要重复一段距离的话,又要修这两条路的距离最短,自然要覆盖那个两个城市之间最短距离的那个了。

    这个题 题意比题都难理解。另外虽然是水题,只需要找这些线段中的最短线段,但我自己还是WA了几次,原因是要考虑到第一条和最后一条线段是不能被选择为重复的,原因题目中说了: Each highway would connect two different cities.

    代码:

    #include <iostream>
    #include <algorithm>
    #include <cmath>
    #include <vector>
    #include <string>
    #include <cstring>
    #pragma warning(disable:4996)
    using namespace std;
    
    int dis[50002];
    
    int main()
    {
    	int n,i,min,min_x;
    	cin>>n;
    
    	dis[0]=0;
    	min=1000000000;
    	
    	cin>>dis[1];
    	
    	for(i=2;i<n-1;i++)//得考虑到不是第一条线段和最后一条线段的情况
    	{
    		cin>>dis[i];
    		if(dis[i]-dis[i-1]<min)
    		{
    			min=dis[i]-dis[i-1];
    			min_x=i;
    		}
    	}
    	cin>>dis[n-1];
    	
    	if(n>=4)
    	{
    		cout<<min+dis[n-1]<<endl;
    		cout<<min_x+1<<" "<<1<<" "<<n<<" "<<min_x<<endl;
    	}
    	else
    	{
    		cout<<0<<endl;
    	}
    	return 0;
    }
    


    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    深入浅出Mybatis系列(八)---objectFactory、plugins、mappers
    深入浅出Mybatis系列(七)---TypeHandler简介
    深入浅出Mybatis系列(六)---配置详解之typeAliases别名
    深入浅出Mybatis系列(四)---配置详解之properties与environments
    fastjson 的使用总结
    Java 中 Gson的使用
    Lombok介绍、使用方法和总结
    Jackson的使用和定制
    深入浅出Mybatis系列(三)---配置简介(mybatis源码篇)
    深入浅出Mybatis系列(二)---Mybatis入门
  • 原文地址:https://www.cnblogs.com/lightspeedsmallson/p/4785779.html
Copyright © 2011-2022 走看看