zoukankan      html  css  js  c++  java
  • POJ 1125:Stockbroker Grapevine

    Time Limit: 1000MS   Memory Limit: 10000KB   64bit IO Format: %I64d & %I64u

     Status

    Description

    Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way. 

    Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

    Input

    Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules. 

    Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people. 

    Output

    For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes. 
    It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

    Sample Input

    3
    2 2 4 3 5
    2 1 2 3 6
    2 1 2 2 2
    5
    3 4 4 2 8 5 3
    1 5 8
    4 1 6 4 10 2 7 5 2
    0
    2 2 5 1 5
    0

    Sample Output

    3 2
    3 10

    题目给出了一个股票经纪人传信息的网络,第一个N代表这个网络中有多少个股票经纪人。之后给出了每个股票经纪人的情况。他能够传给谁以及其时间,求谁传达整个网络的时间最短,最短时间又是多少。如果这个网络本身是不联通的,那就输出disjoint。


    发现这些图论的算法不知道的时候特别神秘,然后知道每一个是干什么的之后才发现很多都是用一个模板去做题,当然目前自己做的题目都是图论当中比较简单的,所以自己觉得容易,以后应用的时候要好好思考。

    但就这个题目来说,直接floyd套用就好了。而且这道题的数据也很水。

    代码:

    #include <iostream>
    #include <algorithm>
    #include <cmath>
    #include <vector>
    #include <string>
    #include <cstring>
    #pragma warning(disable:4996)
    using namespace std;
    
    int num;
    int dis[105][105];
    int dis_max[105];
    
    void init()
    {
    	int i,j;
    	for(i=1;i<=num;i++)
    	{
    		for(j=1;j<=num;j++)
    		{
    			if(i==j)
    			{
    				dis[i][j]=0;
    			}
    			else
    			{
    				dis[i][j]=1005;
    			}
    		}
    	}
    }
    int main()
    {
    	int i,j,k,i_num;
    	while(cin>>num)
    	{
    		if(num==0)
    			break;
    		init();
    		for(i=1;i<=num;i++)
    		{
    			cin>>i_num;
    			int x,x_dis;
    			for(j=1;j<=i_num;j++)
    			{
    				cin>>x>>x_dis;
    				dis[i][x]=x_dis;
    			}
    		}
    		for(k=1;k<=num;k++)
    		{
    			for(i=1;i<=num;i++)
    			{
    				for(j=1;j<=num;j++)
    				{
    					if(dis[i][k]+dis[k][j]<dis[i][j])
    					{
    						dis[i][j]=dis[i][k]+dis[k][j];
    					}
    				}
    			}
    		}
    		for(i=1;i<=num;i++)
    		{
    			dis_max[i]=0;
    			for(k=1;k<=num;k++)
    			{
    				if(k==i)continue;
    				dis_max[i]=max(dis_max[i],dis[i][k]);
    			}
    		}
    		int max_one=1005,max_c=0;
    		for(i=1;i<=num;i++)
    		{
    			if(dis_max[i]<max_one&&dis_max[i]<=1001)
    			{
    				max_one=dis_max[i];
    				max_c=i;
    			}
    		}
    		if(max_c==0)
    		{
    			cout<<"disjoint"<<endl;
    		}
    		else
    		{
    			cout<<max_c<<" "<<max_one<<endl;
    		}
    	}
    	return 0;
    }
    


    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    Tomcat的配置
    读《大道至简》总结
    manjaro安装minishift
    minishift 部署mysql持久化
    从大神到小白之路minishift 命令补全
    Typora 完美结合 PicGo,写作体验更佳!
    40 个笑到抽筋的神回复,绝了!
    如何写出让同事好维护的代码?
    Google的面试题长啥样?看完被吊打
    Mac 超详细入门指南,备用!
  • 原文地址:https://www.cnblogs.com/lightspeedsmallson/p/4785791.html
Copyright © 2011-2022 走看看