zoukankan      html  css  js  c++  java
  • POJ 1519:Digital Roots

    Digital Roots
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 25766   Accepted: 8621

    Description

    The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit. 

    For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

    Input

    The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

    Output

    For each integer in the input, output its digital root on a separate line of the output.

    Sample Input

    24
    39
    0

    Sample Output

    6
    3

    题意是给出一个数,求每一位的和,如24,就是2+4=6。如果得到的数还是大于等于10的数,就对这个数继续求每一位的和,直到变成个位数。如39>12->3。

    不能更标准的递归了。

    代码:

    #include <iostream>
    #include <algorithm>
    #include <cmath>
    #include <vector>
    #include <string>
    #include <cstring>
    using namespace std;
    
    string out;
    
    void recursion(string test)
    {
    	if(test.length()==1)
    	{
    		out=test;
    		return;
    	}
    	int i,result=0;
    	for(i=0;i<test.length();i++)
    	{
    		result += test[i]-'0';
    	}
    	int temp;
    	string test2;
    	while(result!=0)
    	{
    		temp=result%10;
    		test2 += temp+'0';
    		result /=10;
    	}
    	recursion(test2);
    }
    
    int main()
    {	
    	string test;
    	
    	while(cin>>test)
    	{
    		if(test=="0")
    			break;
    		recursion(test);
    		cout<<out<<endl;
    	}
    	return 0;
    }
    


    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    业务领域建模Domain Modeling
    用例建模Use Case Modeling
    分析一套源代码的代码规范和风格并讨论如何改进优化代码
    结合工程实践选题调研分析同类软件产品
    如何提高程序员的键盘使用效率
    python知识准备及环境配置
    一张图片在Python操作下的4种玩法(附源码)
    Python中的错误和异常
    当你忘记网站上的密码时怎么办?Python如何快速帮你找回?
    Python最简单的图片爬虫,20行代码带你爬遍整个网站
  • 原文地址:https://www.cnblogs.com/lightspeedsmallson/p/4785802.html
Copyright © 2011-2022 走看看