zoukankan      html  css  js  c++  java
  • POJ 1256:Anagram

    Anagram
    Time Limit: 1000MS Memory Limit: 10000K
    Total Submissions: 18393 Accepted: 7484

    Description
    You are to write a program that has to generate all possible words from a given set of letters.
    Example: Given the word “abc”, your program should - by exploring all different combination of the three letters - output the words “abc”, “acb”, “bac”, “bca”, “cab” and “cba”.
    In the word taken from the input file, some letters may appear more than once. For a given word, your program should not produce the same word more than once, and the words should be output in alphabetically ascending order.

    Input
    The input consists of several words. The first line contains a number giving the number of words to follow. Each following line contains one word. A word consists of uppercase or lowercase letters from A to Z. Uppercase and lowercase letters are to be considered different. The length of each word is less than 13.

    Output
    For each word in the input, the output should contain all different words that can be generated with the letters of the given word. The words generated from the same input word should be output in alphabetically ascending order. An upper case letter goes before the corresponding lower case letter.

    Sample Input
    3
    aAb
    abc
    acba

    Sample Output
    Aab
    Aba
    aAb
    abA
    bAa
    baA
    abc
    acb
    bac
    bca
    cab
    cba
    aabc
    aacb
    abac
    abca
    acab
    acba
    baac
    baca
    bcaa
    caab
    caba
    cbaa

    Hint
    An upper case letter goes before the corresponding lower case letter.
    So the right order of letters is ‘A’<’a’<’B’<’b’<…<’Z’<’z’.

    题意就是按照字典顺序输出所有字符串。
    正常来说,只需要一个sort,一个next_permutation就OK的题,唯一一个值得说明的就是要把A,B,C这样的大写字母穿插到里面,要不然出来的顺序不会是AaBbCc,而是ABCabc。所以需要自己写一个自定义函数cmp用来比较。我这里为了穿插进去,使用了ASCII码+31.5,就使得每一个大写字母刚好穿进了小写字母中。

    代码:

    #include <iostream>
    #include <algorithm>
    #include <cmath>
    #include <cstring>
    #include <string>
    using namespace std;
    
    char s[5000];
    
    bool cmp(char a,char b)
    {
        double front,behind;
    
        if(a>='A'&&a<='Z')
            front = (double)a+31.5;
        else
            front = (double)a;
    
        if(b>='A'&& b<='Z')
            behind = (double)b+31.5;
        else
            behind = (double)b;
    
        return front<behind;
    }
    int main()
    {
        int count;
        cin>>count;
    
        while(count--)
        {
            cin>>s;
            sort(s,s+strlen(s),cmp);
    
            do
            {
                cout<<s<<endl;
            }while(next_permutation(s,s+strlen(s),cmp));
        }
    
        return 0;
    }
    

    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    Non Clustered Confluence: Database is being updated by another Confluence instance
    晦涩时光 浮光掠影
    迷雾重重 星光闪耀
    navicat 查询窗口快捷键
    sublime使用技巧记录
    mvn 手动打包并放置到本地仓库下
    git bash 风格调整(显示中文)
    windows控制台(console)乱码
    java调用第三方命令,process.waitfor()挂起(你不知道的坑)
    shell问题-报错即退出
  • 原文地址:https://www.cnblogs.com/lightspeedsmallson/p/4785875.html
Copyright © 2011-2022 走看看