zoukankan      html  css  js  c++  java
  • POJ 1146:ID Codes

    ID Codes
    Time Limit: 1000MS Memory Limit: 10000K
    Total Submissions: 6281 Accepted: 3769

    Description
    It is 2084 and the year of Big Brother has finally arrived, albeit a century late. In order to exercise greater control over its citizens and thereby to counter a chronic breakdown in law and order, the Government decides on a radical measure–all citizens are to have a tiny microcomputer surgically implanted in their left wrists. This computer will contains all sorts of personal information as well as a transmitter which will allow people’s movements to be logged and monitored by a central computer. (A desirable side effect of this process is that it will shorten the dole queue for plastic surgeons.)

    An essential component of each computer will be a unique identification code, consisting of up to 50 characters drawn from the 26 lower case letters. The set of characters for any given code is chosen somewhat haphazardly. The complicated way in which the code is imprinted into the chip makes it much easier for the manufacturer to produce codes which are rearrangements of other codes than to produce new codes with a different selection of letters. Thus, once a set of letters has been chosen all possible codes derivable from it are used before changing the set.

    For example, suppose it is decided that a code will contain exactly 3 occurrences of a', 2 ofb’ and 1 of `c’, then three of the allowable 60 codes under these conditions are:

      abaabc
    
      abaacb
    
      ababac
    

    These three codes are listed from top to bottom in alphabetic order. Among all codes generated with this set of characters, these codes appear consecutively in this order.

    Write a program to assist in the issuing of these identification codes. Your program will accept a sequence of no more than 50 lower case letters (which may contain repeated characters) and print the successor code if one exists or the message `No Successor’ if the given code is the last in the sequence for that set of characters.

    Input
    Input will consist of a series of lines each containing a string representing a code. The entire file will be terminated by a line consisting of a single #.

    Output
    Output will consist of one line for each code read containing the successor code or the words ‘No Successor’.

    Sample Input
    abaacb
    cbbaa
    #

    Sample Output
    ababac
    No Successor

    这道题是要输出给定字符串的字典顺序的下一个,如果没有下一个,则输出No Successor。

    字典序如下:
    设P是1~n的一个全排列:p=p1p2……pn=p1p2……pj-1pjpj+1……pk-1pkpk+1……pn
    1)从排列的右端开始,找出第一个比右边数字小的数字的序号j(j从左端开始计算),即 j=max { i | pi < pi+ 1}
    2)在pj的右边的数字中,找出所有比pj大的数中最小的数字pk,即 k=max{i|pi>pj}(右边的数从右至左是递增的,因此k是所有大于pj的数字中序号最大者)
    3)对换pj,pk
    4)再将pj+1……pk-1pkpk+1……pn倒转得到排列p’=p1p2…..pj-1pjpn…..pk+1pkpk-1…..pj+1,这就是排列p的下一个排列。

    上面这一段话摘自百度百科,之前的理解只是知道比方说 123
    字典顺序就是
    1 2 3
    1 3 2
    2 1 3
    2 3 1
    3 1 2
    3 2 1
    但根据上面的方法其实就可以写出求下一个字典顺序的字符串了。12345是起始,54321是终止。
    比方说:13254
    想找下一个字典顺序,找符合大小关系的。
    发现5>4,pass。
    2<5,perfect。
    就是2了,从2这里入手。之后只需要在后面的5 4 中找一个比2大的最小的数,对换。此时序列变为1 3 4 5 2。
    再然后,对4后面的序列,进行正常从小到大排列,就是要找的下一个字典排序。
    1 3 4 2 5。

    所以,可以直接根据这个思想,写出代码

    #include <iostream>
    #include <cstring>
    #include <string>
    #include <algorithm>
    using namespace std;
    
    int front,behind;
    string a;
    
    bool find()
    {
        int len =a.length()-1;
        while(len>0)
        {
            if(a[len-1] >= a[len])
            {
            }
            else
            {
                front = len-1;
                return true;
            }
            len--;
        }
        return false;
    }
    
    void change()
    {
        int len =a.length()-1;
        int min=200;
    
        while(len>front)
        {
            if(a[len]>a[front]&&(int)a[len]<min)
            {
                min=len;
            }
            len--;
        }
        char temp=a[min];
        a[min]=a[front];
        a[front]=temp;
    }
    
    void sort()
    {
        int len = a.length();
        int i,j;
        char temp;
    
        for(i=front+1;i<len;i++)
        {
            for(j=i;j<len;j++)
            {
                if(a[i]>a[j])
                {
                    temp=a[i];
                    a[i]=a[j];
                    a[j]=temp;
                }
            }
        }
    }
    
    int main()
    {
        while(cin>>a&&a!="#")
        {
            if(find())
            {
                change();
                sort();
                cout<<a<<endl;
            }
            else
            {
                cout<<"No Successor"<<endl;
            }
        }
        return 0;
    }

    当然这个题,在algorithm.h文件中,有直接可以使用的字典顺序的函数next_permutation(),具体代码如下

    #include <iostream>
    #include <cstring>
    #include <string>
    #include <algorithm>
    using namespace std;
    
    int main()
    {
        string a;
        while(cin>>a&&a!="#")
        {
            if(next_permutation(a.begin(),a.end()))
            {
                cout<<a<<endl;
            }
            else
            {
                cout<<"No Successor"<<endl;
            }
        }
        return 0;
    }

    这里面的next_permutation()函数就是求其下一个字典顺序,和prev_permutation()函数相对应,使用用法有一些像sort函数,可以对int数组 ,char数组,string类型进行字典顺序查找,也可以在第三个参数加上cmp函数,自己自定义的一个排序函数。具体用法可以参考POJ 1256这道题,体现的比较明显。

    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    下载及爬取网页内容
    对于for循环的理解
    记录安装fiddle出现的问题
    Django
    12种可以参考的思路关于代码能干什么
    “字符文本中字符太多”错误及解决方法
    jQuery参考:jquery中的$(document).ready()与window.onload的区别
    页面定时刷新功能实现
    HTML:关于位置的几个概念
    Lambda表达式
  • 原文地址:https://www.cnblogs.com/lightspeedsmallson/p/4785876.html
Copyright © 2011-2022 走看看