zoukankan      html  css  js  c++  java
  • HDU 5272 : Dylans loves numbers

    Dylans loves numbers

    Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
    Total Submission(s): 274 Accepted Submission(s): 181

    Problem Description
    Who is Dylans?You can find his ID in UOJ and Codeforces.
    His another ID is s1451900 in BestCoder.

    And now today’s problems are all about him.

    Dylans is given a number N.
    He wants to find out how many groups of “1” in its Binary representation.

    If there are some “0”(at least one)that are between two “1”,
    then we call these two “1” are not in a group,otherwise they are in a group.

    Input
    In the first line there is a number T.

    T is the test number.

    In the next T lines there is a number N.

    0≤N≤1018,T≤1000

    Output
    For each test case,output an answer.

    Sample Input
    1
    5

    Sample Output
    2

    题意很简单,判断一个数变成二进制之后,被0分开的1有多少个。
    对一个数变为二进制之后,从右至左开始检验,前一个数是re,正在验的数是cur,如果满足re为0而cur为1,则分出一组,记录下来即可。

    代码:

    #include <iostream>
    #include <algorithm>
    #include <cmath>
    using namespace std;
    
    long long result(long long s)
    {
        long long test=s;
        int re=0;
        long long sum=0;
        while(test)
        {
            int cur = test&1;
            if(re==0&&cur==1)
            {
                sum++;
            }
            re=cur;
            test=test>>1; 
        }
        return sum;
    }
    
    int main()
    {
        int test;
        cin>>test;
    
        while(test--)
        {
            long long s;
            cin>>s;
            cout<<result(s)<<endl;
        }
        return 0;
    }

    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    【转载】久坐如吸烟
    【转载】实用的人际关系经验
    【原创】Apache服务器500错误失去响应的问题解决
    【原创】JAVA word转html
    【原创】Linux下的ngix服务器安装步骤
    【原创】Apache和基于虚拟主机的Tomcat集群方案
    网络编程基础知识
    多线程1
    字符流
    字节流
  • 原文地址:https://www.cnblogs.com/lightspeedsmallson/p/4785877.html
Copyright © 2011-2022 走看看