zoukankan      html  css  js  c++  java
  • POJ3616:Milking Time

    Milking Time
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 5682   Accepted: 2372

    Description

    Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

    Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri <ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

    Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

    Input

    * Line 1: Three space-separated integers: NM, and R
    * Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

    Output

    * Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

    Sample Input

    12 4 2
    1 2 8
    10 12 19
    3 6 24
    7 10 31

    Sample Output

    43

    题意:在各段时间之内产牛奶的数量不同,有休息时间,过了休息时间之后才能继续产牛奶。问总共能产多少牛奶。


    代码:

    #include <iostream>
    #include <algorithm>
    using namespace std;
    
    struct node{
    	int start;
    	int end;
    	int ef;
    }eff[1005];
    
    int dp[1000005];
    bool cmp(struct node node1,struct node node2)
    {
    	if(node1.start==node2.start)
    		return node1.end<node2.end;
    	else
    		return node1.start<node2.start;
    }
    
    int main()
    {
    	int N,M,R;
    	cin>>N>>M>>R;
    
    	int i,j;
    	for(i=1;i<=M;i++)
    	{
    		cin>>eff[i].start>>eff[i].end>>eff[i].ef;
    		eff[i].end+=R;
    	}
    	sort(eff+1,eff+M+1,cmp);
    
    	memset(dp,0,sizeof(dp));
    
    	for(i=1;i<=M;i++)
    	{
    		dp[eff[i].end]=eff[i].ef;
    	}
    
    	int max_i;
    	for(i=1;i<=M;i++)
    	{
    		max_i=0;
    		for(j=1;j<i;j++)
    		{
    			if(eff[j].end<=eff[i].start)
    			{
    				if(dp[eff[j].end]>max_i)
    				{
    					max_i=dp[eff[j].end];
    				}				
    			}
    		}
    		dp[eff[i].end]=max(max_i+eff[i].ef,dp[eff[i].end]);
    	}
    	max_i=0;
    	for(i=1;i<=M;i++)
    	{
    		if(dp[eff[i].end]>max_i)
    		{
    			max_i=dp[eff[i].end];
    		}	
    	}
    	cout<<max_i<<endl;
    
    	return 0;
    }



    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    刚才遇到了关于C#使用外部DLL函数上的char*的问题。
    重新整理过的 《C#编码规范》
    晕,完全晕了。
    Microsoft Visual Studio 2010 支持html5和css3的补丁包
    [mysql] 修改root密码和查看连接数
    Visual Studio统计有效代码行数
    [c#] 邮件附件为中文名的bug
    游戏名词解释
    [SVN] 以下后缀文件不应该提交入库
    [c#] 语言新特性
  • 原文地址:https://www.cnblogs.com/lightspeedsmallson/p/4785885.html
Copyright © 2011-2022 走看看