zoukankan      html  css  js  c++  java
  • hdu 4861 Couple doubi

    Couple doubi

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 607    Accepted Submission(s): 435


    Problem Description
    DouBiXp has a girlfriend named DouBiNan.One day they felt very boring and decided to play some games. The rule of this game is as following. There are k balls on the desk. Every ball has a value and the value of ith (i=1,2,...,k) ball is 1^i+2^i+...+(p-1)^i (mod p). Number p is a prime number that is chosen by DouBiXp and his girlfriend. And then they take balls in turn and DouBiNan first. After all the balls are token, they compare the sum of values with the other ,and the person who get larger sum will win the game. You should print “YES” if DouBiNan will win the game. Otherwise you should print “NO”.
     

    Input
    Multiply Test Cases. 
    In the first line there are two Integers k and p(1<k,p<2^31).
     

    Output
    For each line, output an integer, as described above.
     

    Sample Input
    2 3 20 3
     

    Sample Output
    YES NO
     

    Author
    FZU
     

    Source
     

    题解:水平有点渣,比赛时打表看规律写的。


    #include <iostream>
    #include <cstdio>
    using namespace std;
    
    int main()
    {
        int k,p;
        while(cin>>k>>p)
        {
            if(p)
    
            if(k/(p-1)%2==0) cout<<"NO"<<endl;
            else cout<<"YES"<<endl;
        }
        return 0;
    }




  • 相关阅读:
    bzoj1059: [ZJOI2007]矩阵游戏
    NEW
    bzoj2438: [中山市选2011]杀人游戏
    bzoj4554: [Tjoi2016&Heoi2016]游戏 二分图匹配
    【高精度】模板 (C++)
    【BZOJ4025】二分图 LCT
    读入/输出模板
    一些 Markdown 语法
    题解 P3732 [HAOI2017]供给侧改革
    题解 CF1598A Computer Game
  • 原文地址:https://www.cnblogs.com/liguangsunls/p/6819914.html
Copyright © 2011-2022 走看看