zoukankan      html  css  js  c++  java
  • Big Number HDU

    Big Number

    Problem Description
    As we know, Big Number is always troublesome. But it's really important in our ACM. And today, your task is to write a program to calculate A mod B.
    To make the problem easier, I promise that B will be smaller than 100000.
    Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.
     
    Input
    The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.
     
    Output
    For each test case, you have to ouput the result of A mod B.
     
    Sample Input
    2 3 12 7 152455856554521 3250
     
    Sample Output
    2 5 1521
     
    Author
    Ignatius.L
     
    题意:
    给出正整数 A 和 B,求 A mod B。
     
    思路:
    模拟除法运算即可。
     
    例:
     
     
     
    代码:
    #include <set>
    #include <map>
    #include <list>
    #include <stack>
    #include <queue>
    #include <deque>
    #include <cmath>
    #include <string>
    #include <vector>
    #include <cstdio>
    #include <cstring>
    #include <cstdlib>
    #include <sstream>
    #include <iostream>
    #include <algorithm>
    #include <unordered_map>
    #define INF 0x3f3f3f3f
    #define ll long long
    #define ull unsigned long long
    #define fcio ios::sync_with_stdio(false); cin.tie(0); cout.tie(0)
    using namespace std;
    
    int main()
    {
        string a;
        int b;
        while(cin>>a>>b)
        {
            int t=0;
            for(int i=0;i<a.size();i++)
            {
                t=t*10+a[i]-'0';
                t=t%b;
            }
            cout<<t<<endl;
        }
    }
     
  • 相关阅读:
    JS判断年月
    斐波那契数列
    webkit 控件供vb 6 调用,不错~
    webkit com wrapper 推荐!
    firefox usercontrol for donet
    [z] How can we render CSS3 in a WebBrowser Control ?
    A simple way to crack VBA password in Excel file
    putty教程
    Putty建立隧道的方法[z]
    Step By Step Hibernate Tutorial Using eclipse WTP[z]
  • 原文地址:https://www.cnblogs.com/lihahahahaji/p/13396827.html
Copyright © 2011-2022 走看看