zoukankan      html  css  js  c++  java
  • Bi-shoe and Phi-shoe LightOJ

    Bi-shoe and Phi-shoe

    Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,

    Score of a bamboo = Φ (bamboo's length)

    (Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.

    The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.

    Input

    Input starts with an integer T (≤ 100), denoting the number of test cases.

    Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].

    Output

    For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.

    Sample Input

    3

    5

    1 2 3 4 5

    6

    10 11 12 13 14 15

    2

    1 1

    Sample Output

    Case 1: 22 Xukha

    Case 2: 88 Xukha

    Case 3: 4 Xukha

    题意:

    给出 n 个数字的序列 a[n] , 对于每个数字ai 找到一个数字 bi 使得 bi的欧拉函数值大于等于 a ,求满足条件的 bi 的和的最小值sum.

    思路:欧拉函数打表后对于每个a 从 a+1 开始遍历,寻找满足条件的最小的b求和即可。

    代码:

    #include <set>
    #include <map>
    #include <list>
    #include <stack>
    #include <queue>
    #include <deque>
    #include <cmath>
    #include <string>
    #include <vector>
    #include <cstdio>
    #include <cstring>
    #include <cstdlib>
    #include <sstream>
    #include <iostream>
    #include <algorithm>
    #include <unordered_map>
    #define INF 0x3f3f3f3f
    #define ll long long
    #define ull unsigned long long
    #define fcio ios::sync_with_stdio(false); cin.tie(0); cout.tie(0)
    using namespace std;
    const int maxn=1e6+10;
    int euler[maxn];
    void dbeuler(void)
    {
        for(int i=0;i<maxn;i++) euler[i]=i;
        for(int i=2;i<maxn;i++)
        {
            if(euler[i]==i)
            {
                for(int j=i;j<maxn;j+=i) euler[j]=euler[j]/i*(i-1);
            }
        }
    }
    
    int main()
    {
        dbeuler();
        int n;
        int t;
        cin>>t;
        for(int k=1;k<=t;k++)
        {
            cin>>n;
            ll sum=0;
            for(int i=0;i<n;i++)
            {
                int a;
                cin>>a;
                for(int j=a+1;j<maxn;j++)
                {
                    if(euler[j]>=a)
                    {
                        sum+=j;
                        break;
                    }
                }
            }
            cout<<"Case "<<k<<": "<<sum<<" Xukha"<<endl;
        }
    }
  • 相关阅读:
    大数据基础文献综述
    牛客网数据库SQL实战
    Leetcode with Python
    tinyMCE
    HTTP LVS
    采坑大全
    Hadoop 解除 NameNode is in safe mode
    R语言采坑系列——Warning message: In validDetails.polygon(x) : 强制改变过程中产生了NA
    .Net中的异步编程
    知识点4
  • 原文地址:https://www.cnblogs.com/lihahahahaji/p/13397755.html
Copyright © 2011-2022 走看看