zoukankan      html  css  js  c++  java
  • 1078 Hashing (25 分)

    1078 Hashing (25 分)

    The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

    Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤104) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print “-“ instead.

    Sample Input:

    1
    2
    4 4
    10 6 4 15

    Sample Output:

    1
    0 1 4 -

    作者: CHEN, Yue

    单位: 浙江大学

    时间限制: 400 ms

    内存限制: 64 MB

    代码长度限制: 16 KB

    题目大意

    给出一个hashtable的大小,采用平方探测法,求插入各元素的位置。当表大小不为素数时,要转化为比它大的第一个素数。

    分析

    不算难,转化大小很简单,主要在这个平方探测上面。 是(key + step * step) % size 而不是(key % size + step * step), 知道了这个,就比较好办了。最后一个测试点刚开始不过,查了半天,后来把main中定义的变量改成全局的就过,醉了。估计是最后一个测试点数据大,局部变量栈上分配不出空间来。

    代码

    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    < 大专栏  1078 Hashing (25 分)span class="line">36
    37
    38
    39
    40
    41
    42
    43

    #include <vector>
    #include <algorithm>
    #include <deque>
    #include <map>
    #include <set>
    #include <cstring>
    #include <cmath>
    #include <sstream>

    using namespace std;
    int tsize, n;
    int table[10010], tmp, step;

    bool (int num) {
    if (num == 1) return false;
    for (int i = 2; i * i <= num; i++)
    if (num % i == 0) return false;
    return true;
    }

    int main() {
    cin >> tsize >> n;
    while (!isprime(tsize))tsize++;
    for (int i = 0; i < n; i++) {
    step = 0;
    cin >> tmp;
    int pos = tmp % tsize;
    while (pos < tsize && table[pos] != 0 && step < tsize) {
    pos = (tmp + step * step) % tsize;
    step++;
    }
    if (i != 0)
    cout << ' ';
    if (table[pos] == 0) {
    table[pos] = 1;
    cout << pos;
    } else {
    cout << '-';
    }
    }
    return 0;
    }
  • 相关阅读:
    Python pip – error: invalid command ‘bdist_wheel’
    css实现文字两端对齐(兼容所有浏览器)
    webpack中的require.context
    node 的path模块中 path.resolve()和path.join()的区别
    react-native项目中遇到的问题
    react-native针对android改变状态栏样式
    createBottomTabNavigator: 怎么在切换tab的时候让页面重新渲染
    当vue页面异步加载的数据想在页面上渲染怎么办
    git分布式版本控制系统
    $router和$route的区别,路由跳转方式name 、 path 和传参方式params 、query的区别
  • 原文地址:https://www.cnblogs.com/lijianming180/p/12046795.html
Copyright © 2011-2022 走看看